Support » Fixing WordPress » Comments are Gone on my blog!

Viewing 15 replies - 1 through 15 (of 15 total)
  • esmi

    (@esmi)

    Forum Moderator

    Have you tried:

    – deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the default theme to rule out any theme-specific problems.

    resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    I did try repair comments in PhpMyAdmin….let me go check out the plugins…man! it was working so great, too! dang

    What twentytwelve theme? I have one theme KimberlyRae! Turning off plugins no help

    esmi

    (@esmi)

    Forum Moderator

    Re-upload the default WordPress theme – Twenty Twelve – via Appearance -> Themes and activate it.

    Humm…maybe in my functions?
    is this correct?

    <?php

    if ( function_exists(‘register_sidebar’) )
    register_sidebar();

    ?>

    yeah, now my comments are there! BUT I’ve Never had this theme in all these years and all was working this morning even my numbered comments!!!

    I reactivated the KimberlyRae Theme and now I can see it says the number of comments, click on that and NO comments!

    esmi

    (@esmi)

    Forum Moderator

    Then the issue is within your theme. If this is a custom theme, then you need to contact the developer who created it for you.

    It’s worked since 2006!
    I just noticed if I make any changes in wordpress dashboard after hitting ‘update’ the screen goes to White and my blog says Waiting for kreationsbykimberlyrae.com–this is something never happened before….before I would just hit update and it stays on the page and never does my .com say waiting..

    And what about?

    http://wordpress.org/support/topic/commentphp-file?replies=10

    And you have 150+ validation errors on your page(s)?

    This is the code in comments.php:

    <?php
    if (!empty($_SERVER['SCRIPT_FILENAME']) && 'comments.php' == basename($_SERVER['SCRIPT_FILENAME']))
    	die ('Please do not load this page directly. Thanks!');
    if ( post_password_required() ) {
    	echo '<p class="leavecomment">This post is password protected. Enter the password to view comments.</p>';
    	return;
    }
    
    if ( have_comments() ) : ?>
    <h3 id="comments"><?php comments_number( 'Leave a Comment, 'One Comment, '% Responses);?>to “<?php the_title(); ?>”</h3>
    
    <ol id="commentlist">
    <?php $i = 1; ?>
    <?php foreach ($comments as $comment) : ?>
    <li <?php comment_class(); ?> id="comment-<?php comment_ID() ?>">
    <?php echo get_avatar( $comment, 32 ); ?>
    <?php comment_text() ?>
    <p><cite><?php comment_type(_c('Comment|noun'), __('Trackback'), __('Pingback')); ?> <?php _e('by'); ?> <?php comment_author_link() ?> — <?php comment_date() ?> @ <a>"><?php comment_time() ?></a></cite> <?php edit_comment_link(__("Edit This"), ' |'); ?></p>
    <div class="commentnumber"><?php echo $i; ?></div>
    
    <?php $i++; ?>
    <?php endforeach; ?>
    
    <div class="navigation">
    <div class="alignleft"><?php previous_comments_link() ?></div>
    <div class="alignright"><?php next_comments_link() ?></div>
    </div>
    <?php else : // this is displayed if there are no comments so far ?>
    	<?php
    	if ( comments_open() ) {
    		// If comments are open, but there are no comments.
    	} else {
    		// comments are closed
    		echo '<p class="nocomments">Comments are closed.</p>';
    	}
    endif;
    
    // display the comments form
    comment_form();

    [Please post code or markup between backticks or use the code button. Or better still – use a pastebin. Your posted code may now have been permanently damaged/corrupted by the forum’s parser.]

    WPyogi-that was when I was trying to use Greg’s number thread…it didn’t work until my ISP updated last week and I noticed this morning it was working–I was Thrilled! THE ONLY thing I changed was in the Comment. php above was a ‘Space’ between ‘responses by’ so there would be a ‘space’ between the two words BUT as you can see I took the space out…now the the words ‘responses’ and ‘to’ are slured together. Which I don’t want.

    esmi

    (@esmi)

    Forum Moderator

    It’s worked since 2006!

    During which time we’ve had between 18 and 24 WordPress updates. Your theme is actually very old and probably needs completely updating.

    Hummm…true. Only problem is I’m not a programmer [lol couldn’t tell] and the girl that did mine originally turned out to be a hacker a couple years after I paid her to do my blog and hacked up my shop that I used to do business…because of that experience biz went south and my isp had to get it up and going again…blah…
    PS how do I edit to get the code I put in here and delete it?? THANKSs

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Comments are Gone on my blog!’ is closed to new replies.