WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] Comments are closed, I can’t open them – and there are NO universal settings

[Resolved] Comments are closed, I can’t open them – and there are NO universal settings

  • Okay, this is odd.

    I noticed this morning that a blog post I wrote *last* week which got a tremendous amount of traction had closed comments. I didn’t disable them so I went to the blog post and tried to check “allow comments” and “allow pingbacks.” The checkboxes were active, but when I went to Update Post, they disappeared. I was back to sqaure one with closed comments.

    I have no idea what happened, but I don’t have anything in my error_logs. I don’t automatically close posts after a certain time. My earlier posts (from 2+ weeks ago) are still intact. It is just this post with 141 comments that automatically closed the comments and I have simply no idea why.

    I had to manually go into the database and set “closed” to open, but I want to prevent this from recurring (perhaps it’s going to happen again). First of all, why did it happen? It sounds pretty malicious to me, and as the universal admin user, shouldn’t I be able to override this? Again, there are no universal settings and I don’t have plugins that interfere with comment closure.

    I’m baffled and I’m pretty tech savvy to know that this is super abnormal.

    Help?

Viewing 15 replies - 1 through 15 (of 37 total)
  • Moderator James Huff

    @macmanx

    Check Settings/Discussion in your admin panel.

    Make sure that “Allow people to post comments on new articles” is checked and that “Automatically close comments on articles older than [x] days” is unchecked.

    macmanx,

    Like I said in my earlier post, there are no universal settings overriding my individual comment settings on posts (as in what you’re referencing) and I don’t have plugins that interfere with comment closure.

    I also mentioned that all my earlier posts do not have closed comments. It was only my LATEST post that was closing comments despite me electing to keep comments open.

    Obviously this isn’t a normal issue. What else can it be?

    Are there logs that I can check? I mentioned I checked error_log and nothing there was out of the ordinary. I think WordPress needs its own type of error_log to assess…

    Moderator James Huff

    @macmanx

    Can you provide a link to your blog to so we can do some investigative work?

    Sure, it’s techipedia.com. The post in question is now the second post listed. It’s fine now because I had to go into the database and update the variables from “closed” to “open” under allow comments/allow pings. I have no idea why I had to manually make such a change.

    Moderator James Huff

    @macmanx

    Even if you don’t have plugins that interfere with comment closure, a glitch in any one could be causing the problem. Typically, I would suggest deactivating all plugins to see if that resolves the issue, then reactive each individually until you find the cause. But, since the problem doesn’t occur immediately, that would be kind of pointless.

    Here are three things that I would try:

    1. Make sure that WordPress and all of your plugins are up-to-date.
    2. Deactivate and delete any unnecessary plugins.
    3. Repair your WordPress database. To do this, access the database via phpMyAdmin (most hosting providers offer this via their control panel), check all of the tables in the database, and choose “Repair table” from the pull-down menu.

    This is not working and now another one of my posts is having the same issue. What is going on? 🙁

    Same problem here. Comments are turned on globally as well as for each of my posts. but all posts say “Comments are Closed” and show no form. Even posts with comments added already will no longer allow commenting.

    I’ve searched all over for this and saw some solutions, but none of them work. This looks to be a pretty serious bug!!! HELP!

    Ditto here. I’m running an older version of WordPress (2.6) and it decides periodically to change its own settings, most obviously — and obnoxiously — by closing comments on all posts, requiring users to register and log in before commenting, and insisting that an admin approve the comments.

    I don’t require readers to register before commenting, but WP occasionally overrules me. Without any input from the meatware it checks the General Settings box “Users must be registered and logged in to comment.” Then, under Discussion Settings, it will check the box “An administrator must always approve the comment.” Finally, it unchecks the Allow Comments box on each and every post I’ve ever made.

    Once WP has taken me down this dark and dreary path the only way to re-enable comments is to uncheck these two boxes and then go back through as many posts as I can bear, checking the Allow Comments box.

    I don’t use any plugins. My WordPress is obviously not up to date, but my hosting provider (Hostcentric) is only up to 2.7, so I’m not certain a software update will provide much help. And I haven’t tried repairing the database yet. The site is http://www.maddogmedia.com/wordpress.

    Ditto here, running WordPress 2.9.2

    Can see comments if I’m logged in as admin, but when logged out, it says comments are closed.

    Discussion Settings: Checked – Comment author must fill out name and e-mail everything else unchecked except:
    An administrator must always approve the comment.
    When I edit the post, the boxes are still checked to allow comments and trackbacks.

    I’m running heaps of plugins on said blog, so I’m not going to upgrade to WordPress 3 yet because most won’t be ready for it, so I’m going to try macmanx’s suggestion and see if it’s a plugin that is causing it, and repair database. Will post back if I got anywhere.

    I’m running heaps of plugins on said blog, so I’m not going to upgrade to WordPress 3 yet because most won’t be ready for it, so I’m going to try macmanx’s suggestion and see if it’s a plugin that is causing it, and repair database. Will post back if I got anywhere.

    Repaired/Optimized Database = no difference
    Disabled all plugins = all comments came back.

    Now to figure out which plugin is the culprit 🙁

    Hmm, the plugin culprit was MemberWing – I guess that makes sense, probably some setting in there that causes all comments to be closed except for members.

    Crisis over, at least for me, but I dare say that my problem wasn’t the same as the others above.

    Saw this thread and I have similar problems.
    If someone has some more tip on how to solve the problem, please post.
    I will post back if I find a solution somewhere.
    I have checked James (MacManX) 3 suggestions but no change.
    I might go on with inactivate many more plugins than those that I think is relevant in this context.
    ……
    comments are closed on all my posts…
    comments are open on all my pages…
    if I click on Leave comments on a page nothing happens…(isn´t it supposed to roll down to comment form….?)

    SETTINGS:
    —–
    all my posts have checks in:
    Allow Comments.
    Allow trackbacks and pingbacks on this page.

    in Settings/Diskussion I have:
    comments on.
    I have tried all on – and close comments after 600 days.
    nothing change…

    Permalink is customed structur – /%postname%/
    (I have pretty link plugin)
    (I have tried Default-setting but no change…)

    I have tried to inactivate some plugs – but no change…

    I have compared the comment.php in WinMerge with the original file.
    No essential changes.(just some translation)

    problems:

    1. Why is my comments closed..?
    2. Shouldn´t the page roll down to form when clicking the Leave Comment…?

    Anybody who has any tip on this, please post. I really now don´t know what to do…
    The comments are important to have on – so I´d like to fix it.

    I have (THEME FORTE)

    kind regards

    mike

    forgot:
    + I have also tried bulk-edit posts to allow comments and trackbacks – but no change.

    mike

    Moderator James Huff

    @macmanx

    Try deactivating all plugins (not just those that you think are relevant). If that resolves the issue, reactivate each one individually until you find the cause.

    If that does not resolve the issue, try switching to the Default theme (WordPress 1.5 – 2.9.2) or the Twenty Ten theme (WordPress 3.0 and higher) to rule-out a theme-specific issue.

    If that does not resolve the issue, you may need to repair the database. Access your WordPress database via phpMyAdmin (most hosting providers offer this in their control panel), check all of the tables, and choose “Repair tables” from the pull-down menu.

    nice of you to respond Mac…

    yes, I will do the plugs and maybe check the theme.
    (but I don´t think it´s the theme – and the comments.php seems alright when I compare against the original in WinMerge)

    I have already repaired the db according to your advice.
    (no change)

    but I have another lead.

    I use Greg´s SEO – and in the instructions there is a mention of:

    Paged Comments
    ….
    Greg’s High Performance SEO enables you to remove comment page duplicate content, distinguish comment pages by their titles and secondary titles, and provide distinct head meta information and secondary descriptions. Paged comment modifications don’t require any additions to your theme, except to the extent that taking advantage of modifications to secondary titles and secondary descriptions requires enabling those capabilities of the plugin in your theme files.
    …..

    Might it be this SEO plug that remove comments from posts – pages works just fine – and tries to hinder duplicate content….?

    I have to look into this too.

    It´s not good when comments don´t work. It´s a important feature in a site.
    I also like to be so errorfree as possible before I update to WP 3.x.

    I post the solution if I find some.

    regards

    mike

    ok..

    I have Inactivated maybe 70 % of the plugins – no change!
    I have also inactivated my Gregs SEO plug and removed the the specific code for this plug – but no change.
    …………

    but!

    when I changed theme there was normal comments-function again.
    (with the box and no text)

    so the conclusion is that it is very likely a theme issue.
    but here I haven´t a clue.
    I have checked the comments.php against the original and it seems not corrupt.
    (the only changes is the translations – but no changes in code)

    If MacManX or anybody has some tip it is very appreciated.

    Here is the adress if it´s any help:
    http://mickansandelin.se/blog/

    NOTE: The pages is alright – it is the posts that is closed.
    (with text:
    Kommentarer för ämnet i detta inlägg är avstängt av författaren
    transl:Comments for issue in this post is closed by the author

    regards

    mike

Viewing 15 replies - 1 through 15 (of 37 total)
  • The topic ‘[Resolved] Comments are closed, I can’t open them – and there are NO universal settings’ is closed to new replies.
Skip to toolbar