WordPress.org

Forums

Comments are always being held for moderation (9 posts)

  1. kissmykitty
    Member
    Posted 6 years ago #

    I'm having a problem that started when I upgraded to 2.7 beta2, and it has persisted even now with beta3. Basically, ALL comments are being held for moderation, regardless of how many times the comment authors have commented before.

    Under Settings > Discussion I have made sure that "An administrator must always approve the comment" is unchecked.

    These are the comment-related plugins that I have activated:

    • Akismet
    • Author Highlight
    • BM-TrackPing
    • Comment Email Responder
    • Commentluv
    • Comment Relish
    • Official Comments
    • Per post anonymous comments

    (A note on Akismet: I had it deactivated for over a week, hoping that it was the cause of all comments being held for moderation. Unfortunately, deactivating it did not solve the problem.)

    Thank you in advance for any suggestions!

  2. moshu
    Member
    Posted 6 years ago #

    I suggest you report the finding of your test of a beta software to the devs using the proper mailing lists.

    Don't use beta software on live production sites.

  3. kissmykitty
    Member
    Posted 6 years ago #

    Thanks for the suggestion. I'll get this issue reported today.

    I do admit that I am using it on a live site, but I am taking precautions and am having backups of the database emailed to me each day, in case something should suddenly blow up. :)

  4. Familiar
    Member
    Posted 6 years ago #

    With all the changes that have been made to the comment system, I would be quite surprised if the plug-ins you're using weren't the culprit here.

    I would advise disabling any comment-related plug-ins that aren't on the WP2.7 compatibility list.

  5. patrickd88
    Member
    Posted 6 years ago #

    xoxo, did this ever get anywhere? Did you add this to the bug reports? Im having the same problem now as well.

  6. Familiar
    Member
    Posted 6 years ago #

    Patrick are you using any comment plug-ins?

    I just did a quick test with the database, and unlike version 2.6.3, the value for comment_moderation (id 31) is being set to NULL (empty) in wp_options rather than 0 when turned OFF.

    I am not sure if this is the desired operation, as the code indicates it should have a value of 0 when initialized. The check asks for an absolute value of 1 to activate moderation, but the NULL value may be confusing it. Someone want to look into this? Try manually setting the value to 0 in wp_options and see if it functions as you want it, then set it to a NULL value and test it again.

  7. kissmykitty
    Member
    Posted 6 years ago #

    Familiar, I just checked my database, and the value for comment_moderation is already set to 0. FYI, I'm using 2.7-beta3.

  8. Familiar
    Member
    Posted 6 years ago #

    Must've been fixed at some point, which is nice :)

  9. mvanpatten
    Member
    Posted 6 years ago #

    I'm having the problem, just started.
    2.7.1
    I just deactivated comment luv which is only comment plug-in I have.

Topic Closed

This topic has been closed to new replies.

About this Topic