WordPress.org

Support

Support » How-To and Troubleshooting » Comments appear without my approval

Comments appear without my approval

Viewing 5 replies - 1 through 5 (of 5 total)
  • When you set your options, did you remember to click the UPDATE OPTIONS button?
    Yes, I know this sounds silly, but trust me, I’ve made lots of changes to my options before and I have often forgotten to click that button to save my new settings.
    Just a guess…you never know! 🙂

    No, I made that mistake, and others too, but that’s not the problem now.
    I noticed that when I change comment_moderation to Manual in General Blog Settings, it unchecks An administrator must approve the comment in Discussion options. Probably that will be fixed in the 1.3 version.

    Are you by any chance running an older version of WPBlacklist (like 1.2 or 1.21) or another blacklisting plugin as well? The old WPBlacklist had a bug in that it wouldn’t notice a “hold” on a comment made by the WP core and would approve it if the comment passed the blacklist. If you are using WPBlacklist, then get the latest one from here: http://sm.farook.org/files/WPBlacklist261.zip

    No, because I haven’t had any spam yet. I just downloaded WPBlacklist and was going to install it when I needed it.

    Aha, I was running the plugin Optional Comment Moderation 0.3 by Colin D. Devroe. When I deactivated it, the blacklist and the moderation queue started to work. Colin, I see a few problems with that plugin, such as documentation…

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Comments appear without my approval’ is closed to new replies.
Skip to toolbar