Support » Plugins and Hacks » CommentLuv XML Error in some blogs

CommentLuv XML Error in some blogs

  • I’m using CommentLuv in my blog AffectSelling.com and its latest post function works.

    But when I comment on some other blogs, CommentLuv (in those blogs) says, “XML error: junk after document element at line 14, column 1”.

    The weird part is that the feature worked on the other blogs previously.

    Can anyone explain to me what could be the reason?

Viewing 8 replies - 1 through 8 (of 8 total)
  • it looks like your wordpress.com stats plugin is injecting it’s javascript in to the end of the feed that your commentluv plugin sends back when you comment on other commentluv enabled blogs.

    try temporarily deactivating your wordpress.com stats (or you may be using the jetpack plugin) and see if the problem continues

    Thanks for helping.

    You were right, deactivating Jetpack solved the problem. But when I reactivated it the problem too came back. Is there anything I can do (besides not using Jetpack)?

    I think you can find many other statistics plugins that work well with CLP.

    I’ll have to install jetpack on a test site and see why their system is putting the code on to the end of the page and try and counteract it but for now, if you want commentluv to not break then deactivate the stats part of jetpack

    Thanks again.

    If you find a solution, please post it here 😉

    I have that problem with CommentLuv too: XML error: Invalid document end at line 20, column 1. But Jetpack is helpful; well, with the stats thing. So I’m reluctant to disable Jetpack. So far, that’s the only problem I have with CommentLuv. But I still have it active plugin on my blog.

    I am still searching for a solution to jetpack injecting it’s stats code on to every page. I’ve set the is_feed to true in the query but that doesn’t work either 🙁

    I can’t debug jetpack on local because it requires a talkback to activate it so I can’t look and see what code they are using either.

    I’ll keep searching for a solution

    I’m also getting an error when I comment on other commentluv blogs.

    The error is:”This XML document is invalid, likely due to invalid characters. XML error: junk after document element at line 2, column 0″ and as a result i don’t get a link to my last post.
    Am not using jetpack.

    My blog: http://www.blogging-insights.com

    Anyone help please

    @norbert http://blogging-insights.com/ works fine for me on fiddyp.co.uk

    please submit a support ticket with the EXACT urls to where you are seeing this problem and I can look in to it.


Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘CommentLuv XML Error in some blogs’ is closed to new replies.
Skip to toolbar