WordPress.org

Support

Support » How-To and Troubleshooting » Commenting problem…

Commenting problem…

  • Hi everyone,

    I’ve just installed my blog at http://www.learnbassguitartoday.com but i’m recieving the following error when i try to post a comment:

    Structural failure: no comment ID sent to comment hook
    Aborting Spam Karma

    I’ve no idea what that means. I’ve tried using a different theme and looking in my settings but i don’t seem to be having any joy. It’s not just in IE, Firefox is the same. I’ve been trying to leave these comments whilst logged out to test the commenting function.

    I’ve also received the following error from a different PC whilst trying to complete the same task:

    sk2_comment: Cannot fetch comment record from table.
    SQL error: MySQL server has gone away
    Error: Submitted Post_ID variable (1) not matching ours (0).
    get_granularity: query failed.
    Query: SELECT COUNT(*) AS cmt_count, AVG(spams.karma) AS karma_avg FROM wp_comments AS comments LEFT JOIN wp_sk2_spams AS spams ON spams.comment_ID = comments.comment_ID WHERE comments.comment_ID != AND comments.comment_approved = ‘1’ AND comments.comment_date_gmt < DATE_SUB(”, INTERVAL 3 DAY) AND comments.comment_author_IP = ”
    SQL error: MySQL server has gone away
    Error: cannot update comment entry ID: 0 to status: moderated.
    SQL error: MySQL server has gone away
    Cannot update sk2_kSpamTable info (no comment ID provided).

    Any help would be greatly appreciated.

    Many thanks
    Jamie

Viewing 5 replies - 1 through 5 (of 5 total)
Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Commenting problem…’ is closed to new replies.
Skip to toolbar