WordPress.org

Support

Support » How-To and Troubleshooting » Commenting Not Working

Commenting Not Working

  • hi.

    for the past week or so, commenting has not worked on my blog. after I attempt to enter a comment in the comment box at the end of a post, it just redirects me back to the post again — but with no comment posted.

    for instance, try to enter a comment at the bottom of this post: http://obscuresound.com/2011/08/oh-ruin-eoin/

    it brings you back to the same page, but with this as the URL instead: http://obscuresound.com/2011/08/oh-ruin-eoin/#comment-0

    I have comments enabled for all posts. I am also running W3TC, Hyper Cache, and WP Minify, though I have tried disabling all of them but the commenting still does not work. I also recently implemented CloudFlare.

    any suggestions would be greatly appreciated.

    thanks,
    Mike

Viewing 2 replies - 1 through 2 (of 2 total)
  • haven’t found a fix yet. any tips?

    also, it is not a theme-related issue. I disabled this theme and tried a bunch of others, including the default, and the issue persists. some of the themes even bring up a 404 page when attempting to submit a comment.

    You can’t really use multiple performance plugins all at once unless you know exactly what you’re doing. Have you tried disabling all performance plugins and then add them one-by-one (if necessary) until the functionality breaks? Also, you do not need WP minify if you use W3 Total Cache. Also W3 Total Cache is not compatible with hyper cache.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Commenting Not Working’ is closed to new replies.
Skip to toolbar