• Resolved digitalgonzo

    (@bzosel)


    Hi,
    with ASE I disabled comments on all pages, but today I received my first comment for a page…
    How is this possible?

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Bowo

    (@qriouslad)

    @bzosel what theme are you using? On which post types did you disable comments? Can you share the URL of the page where you received comment?

    Thread Starter digitalgonzo

    (@bzosel)

    I use the Hello theme fro Elementor. I disabled it on all post types. This is the URL: https://editions-schortgen.lu/en/privacy-policy/

    Plugin Author Bowo

    (@qriouslad)

    @bzosel I’ve also just tested with Hello Elementor theme and the free version of Elementor. The comment form on the sample page was hidden properly.

    Can you share a screenshot of the actual comment in the WP-admin >> Commments administration screen?

    Also, do you have XML-RPC disabled as well? If not, I suggest you disable that as well from the Security tab in ASE.

    For ASE v5.5.1, I’ll be adding

    add_filter( 'xmlrpc_allow_anonymous_comments', '__return_false' );

    as part of the Disable Comments module, which should prevent posting anonymous comments via XML-RPC.

    Marking this resolved for now. Please submit another report if you still see comments coming in even after disabling XML-RPC.

    • This reply was modified 8 months, 2 weeks ago by Bowo.
    Thread Starter digitalgonzo

    (@bzosel)

    Thanks! According to my hosting company they disable XML-RPC on the server. Therefore I did not activate this option in your tool.
    But normally it should not have been possible to use XML-RPC
    Here the screenshot:

    https://web.tresorit.com/l/YujMY#FhK853PKxKT80oKv-LWmOQ

    • This reply was modified 8 months, 2 weeks ago by digitalgonzo.
    • This reply was modified 8 months, 2 weeks ago by digitalgonzo.
    Plugin Author Bowo

    (@qriouslad)

    @bzosel I’m revisiting ASE’s old(er) support threads to appreciate the feedback you’ve given in improving ASE with a sneak peak of, and discount code you can get for the soon-to-be-released Pro version of ASE.

    If you’re interested, please contact me at https://bowo.io so I can send you the link to the website and the discount code.

    mfentonreb

    (@mfentonreb)

    Hackers can inject comments on a post even when comments are turned off. It’s not the theme. It doesn’t happen often but I’m trying to figure out how to prevent it.

    Plugin Author Bowo

    (@qriouslad)

    @mfentonreb please let me know when you’re able to figure out where such comments are being posted from. It’s been quite a while that this issue does not appear, so I thought it was fixed for good.

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.