Support » Themes and Templates » [Resolved] Comment Template Problem…

[Resolved] Comment Template Problem…

Viewing 4 replies - 1 through 4 (of 4 total)
  • Well first thing to do is fix these errors:


    so we can atleast validate and see what errors. This is the best way to figure out if you’re missing a DIV or something.

    Yep, definitely a surfeit of divs today (for some reason there have been a lot of posts about things not appearing, and in each case there have been unhappy divs floating around)

    line 110 column 28 - Warning: missing </a> before <h1>
    line 112 column 1 - Warning: inserting implicit <a>
    line 113 column 9 - Warning: discarding unexpected </a>
    line 149 column 56 - Warning: replacing <p> by <br>
    line 149 column 56 - Warning: inserting implicit <br>
    line 149 column 56 - Warning: <br> element not empty or not closed
    line 166 column 9 - Warning: discarding unexpected </div>
    line 235 column 1 - Warning: discarding unexpected </div>
    0 errors / 8

    In the default template, a good base to build on, comments are called from within single.php using <?php comments_template(); ?>

    This function calls comments.php

    In comments.php there are no div tags

    So all your div stuff could probably be carried out quite happily in single.php

    If you want to start using divs in comments.php just make sure that each <div> is followed somewhere by a </div>


    Damn, this post wasn’t supposed to be posted. wordpress.org did time out. Had already fixed it…

    peiqinglong, you kind of totally missed my point.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Resolved] Comment Template Problem…’ is closed to new replies.