WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Comment subscription not working

[Resolved] Comment subscription not working

  • Hi,

    I’ve been using Jetpack plugin for a while at http://xmodulo.com

    Initially, blog/comment subscription worked okay, but at some point it stopped working.

    When I check the subscription status at wp-admin/admin.php?page=stats, it shows 3 blog and 3 comment followers. But it has never changed for a couple of months now. I tested subscribing to a comment as a different email address, etc, but the subscription status never changes. I never receive notification for any reply…

    Can someone look into my problem?

    I connect to WordPress.com via username “xmodulo”

    Thanks!
    Dan

    http://wordpress.org/plugins/jetpack/

Viewing 13 replies - 1 through 13 (of 13 total)
  • Btw, I’m not using Jetpack Comments, but using default WordPress comment system. I assumed I am not required to use Jetpack Comments in order to use email subscription.

    Plugin Author Jeremy Herve

    @jeherve

    I just left a test comment on your site. Could you approve it, so I can run some tests on my own?

    Thanks!

    I just approved your comment.
    Thanks for your time!

    Plugin Author Jeremy Herve

    @jeherve

    I left another comment, on another one of your posts as to not disturb other commenters with my test comments.

    Unfortunately, my comment was blocked again, thus also blocking the comment subscription process. Could you check your discussion settings, and make sure that your comment blacklist is not too agressive?

    Thanks!

    I did not set up any blacklist in discussion settings.

    One thing though, I was using anti-spam plugin from:
    http://wordpress.org/plugins/anti-spam/

    I just disabled the plugin, to see if that was the problem.

    Your comment was approved.

    Thanks!

    Plugin Author Jeremy Herve

    @jeherve

    Your blog doesn’t seem to like me very much; all my comments seem to need moderation before they’re published.

    It shouldn’t stop comment subscription emails form being sent, though. Do you use any other comment / captcha / anti spam plugin on your site?

    It was set to manually moderate every comment. I turned that off. But that shouldn’t be the problem.

    I do not use any comment moderation related plugin, other than Akismet. These are the plugins I’m using.

    Ad Injection
    Akismet
    Fancier Author Box
    FD Feedburner Plugin
    Feedburner Email Widget
    Google+ Badge Widget
    Insert Headers and Footers
    Jetpack by WordPress.com
    MaxBlogPress Ninja Affiliate
    OIOpublisher Ad Manager
    Related Posts Thumbnails
    SEO Blogger to WordPress using 301 Redirection
    SyntaxHighlighter Evolved
    W3 Total Cache
    Widget Logic
    Widgets of Posts by Same Categories
    WordPress SEO
    WP Missed Schedule
    Wp Social Toolbar Pro
    Yet Another Related Posts Plugin

    Any thought on why this is happening?

    Plugin Author Jeremy Herve

    @jeherve

    I tried again, and still didn’t receive any confirmation email. The problem is not about the emails not being sent, though: it seems the checked option is not properly recorded when I submit the comment form.

    Could you try to deactivate W3 Total Cache?
    If that doesn’t help, it might be worth switching to a different theme for a few minutes, to make sure the problem is not linked to the comment form itself.

    Let me know how it goes.

    I disabled W3 Total Cache, but that doesn’t seem to help.

    Couple of months ago, my WordPress.com account got suspended for no reason (during that time my site was linked to WordPress.com), and then now I got back the access to my account for some reason. Not sure what was the reason for suspension and reinstatement. Anyway hope this issue is not related to that.

    I switched to a completely different theme some time ago, and I have had this comment issue before and after the theme switch. So I’m not sure whether theme is an issue. I guess I will test more… thanks for your time.

    Plugin Author Jeremy Herve

    @jeherve

    Well that was it! I’m so sorry, I should have thought of checking your WordPress.com account status earlier. I fixed things on our end, and subscription emails appear to be working properly now.
    http://i.wpne.ws/SaWd

    Let me know if you experience more issues!

    Wonderful! It works now! So my WordPress account had subscription disabled somehow. Thanks much for spending time fixing the problem.

    Plugin Author Jeremy Herve

    @jeherve

    It seems to work indeed. Here is a screenshot of the notification I received for your last comment:
    http://i.wpne.ws/SZVC

    Thanks, Jeremy. This thread can be closed now.

    Cheers,
    Dan

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘[Resolved] Comment subscription not working’ is closed to new replies.