Support » Plugin: All In One WP Security & Firewall » Comment SPAM Settings

  • Resolved jessicana

    (@jessicana)


    Hello,

    I have turned the comment SPAM settings on to add a simple math captcha field in the WordPress comments form. I was able to make a post without filling the captcha, I was not asked to fill the captcha and the post went simply online.

    Another thing, I wish that we have the ability to control the location of the captcha. (i.e: below the comments box, above the comments box, etc…).

    Regards

    https://wordpress.org/plugins/all-in-one-wp-security-and-firewall/

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author mra13

    (@mra13)

    The captcha doesn’t get shown when you are logged into the site as admin. Try it from a browser where you are not logged into the site as admin.

    You are right. Thank you!
    One small request, can we change the location of the captcha. (i.e: below the comments box, above the comments box, etc…).

    Plugin Author wpsolutions

    (@wpsolutions)

    can we change the location of the captcha. (i.e: below the comments box, above the comments box, etc…)

    Currently the plugin is specifically using a filter to place the captcha after the comment fields. This is usually the most common and intuitive area to put it.
    Depending on time and workload, we may consider adding a setting to give user the option of placing captcha before the comments fields in a future release.

    For me it appears before the comments field, that’s why I asked, I wish I can place it below the comments box.

    See this: http://goo.gl/IyA67n

    Thanks

    Plugin Author wpsolutions

    (@wpsolutions)

    Actually, that is exactly how it is supposed to work based on the “comment_form_after_fields” filter.

    I don’t think there is another available filter option which caters for cases after the comment text box and before the submit button.

    I wish we have the option to place it before the submit button but after the comment text box.
    KEEP THE GREAT WORK UP. THANK YOU 🙂

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Comment SPAM Settings’ is closed to new replies.