Support » How-To and Troubleshooting » [Resolved] Comment spam blacklist isn't working

[Resolved] Comment spam blacklist isn't working

  • I have a major spam problem on my site at http://www.weightlossladder.com

    Every day I am deleting around 50-100 spam comments. This morning I went into my settings/discussion and under ‘comment blacklist’ I entered the IP addresses and some common spam words eg ‘burberry’ ‘outlet’ one per line as instructed and saved.

    I’m disappointed to see tonight another 35 comments awaiting moderation – including the IP addresses and words such as ‘outlet’ that I had blacklisted. I was expecting these comments to automatically be diverted to the spam folder and I would not receive notification emails for them, or have to manually remove them again.

    I checked my discussion settings and sure enough the words and IP addresses I listed are still there.

    Can anyone enlighten me how to get my comment blacklist working properly or am I missing something? Thanks in advance

Viewing 5 replies - 1 through 5 (of 5 total)
  • Try resetting discussion settings and see if it helps.

    Are you using any plugins to stop comment spam?

    My frank oopinion : the fastest is to chose another antispam solution.

    Akismet DOES the job well, seriously, getting a key takes 2 minutes, only.

    I added the Antispam Bee plugin, you tell this plugin your antispam key, and this is – in my eyes of course – the dream combo, ZERO spam comments pass through, and the rate of false positives (legit combos going to the spam folder) is less than 5 comments per week.

    Thanks for the responses.

    Krishna, how do I reset my discussion settings?

    Sabinou, thank you for the advice. I did install akismet, but I don’t want to pay a monthly fee. I have now deactivated it and deleted it, in case it is interfering somehow.

    I may be forced to give in and get an askimet key, but I like to screw the costs right down. If WordPress provides the free facility to remove spam, I’d rather use that and save the cash.

    David, Akismet is FREE. And you can use Antispam Bee without providing it an akismet key, you’ll only get rare additional false positives and rare additional spam passing through 🙂

    Removing my not-yet-activated akismet has solved the problem, and wordpress is correctly diverting comments with matched ips or words to spam. Thanks again.

    edited to add – Sabinou akismet isn’t free for my category as I’m soon going to add a paid product. I’ll take a look at the plugin you mention – thanks!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Resolved] Comment spam blacklist isn't working’ is closed to new replies.