Support » How-To and Troubleshooting » [Resolved] Comment section not working – page not found

[Resolved] Comment section not working – page not found

  • I’ve looked through forums and can’t find an answer so if someone can help I’d really appreciate it. I have elegant grunge theme and it’s been working fine for several weeks but now when you click to leave a comment this appears:
    Oops!Page Not Found

    The page you tried to access does not exist on this server. This page may not exist due to the following reasons:

    You are the owner of this web site and you have not uploaded (or incorrectly uploaded) your web site. For information on uploading your web site using FTP client software or web design software, click here for FTP Upload Information.

    The URL that you have entered in your browser is incorrect. Please re-enter the URL and try again.

    The Link that you clicked on incorrectly points to this page. Please contact the owner of this web site to inform them of this situation.

    What can I do to fix this? THANKS!

Viewing 12 replies - 1 through 12 (of 12 total)
  • I still can’t figure out why my comments link is not working. Is there anyone out there who can help me? Please? I’m so frustrated!

    Using_Permalinks – that’s what you want to read.

    Thanks. I am still confused. I created a .htaccess file in my root directory (is that right?). I think I’m supposed to give wordpress write access to it but I can’t figure out how. I found this: http://codex.wordpress.org/Changing_File_Permissions
    BUT when I right click on the index.php file there is no “file permissions” option to select. I’m pulling my hair out a little. If you could help I would appreciate it very much!

    What FTP client are you using when “right-clicking”?

    I am using the ftp client through my godaddy account. I’m not sure what it’s called but a java picture pops up when it’s loading. Sorry, I’m a little clueless about this stuff!

    FTP_Clients – find something decent, you will always need it if you plan to run a website. And yes, a blog is a website, and you need to learn the basics for maintanence and customization.

    Downloaded FileZilla, right clicked .htaccess (which is empty), clicked Change File Attributes, then put in numerical value 666. I am still getting the same “page not found” error on my site. I’m trying to figure this out but if you know what to do and are willing to help that would be fantastic. Thanks for your help thus far.

    Maybe, simply, your host doesn’t have what is needed for the nice permalinks to work.
    Anyway, change them back to the default and everything will work.

    And then make sure that every requirement needed is present on your host (see the section #3. in the article linked above). Ask you host if they have those features enabled.

    I called godaddy, asked about Apache web server with the mod_rewrite module. Turns out my hosting account needed to be changed from Windows to Linux. Now everything is working! Thanks again for all your help. I would have thrown my laptop in the pool by now without it.

    Next time be smarter and start in your very first post with this:
    “I am hosted on a Win server at godaddy…”
    and then in about 2 minutes you’ll get the solution: SWITCH to Linux.
    Giving as much details as it’s possible might save you a lot of frustration!

    probably saved yourself a good chunk of money by switching from windows too . . .

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘[Resolved] Comment section not working – page not found’ is closed to new replies.