Support » Fixing WordPress » Comment section for posts not showing up

  • Hello,

    I am having problems with the comment section not showing up for posts on my website.

    I have tried every solution so far:

    + Enabling comments from Settings > Discussion.
    + “Allow people to post comments on new articles” is checked
    + Comment must be manually approved is UNchecked
    + Automatically close comments on articles older than X days is UNchecked
    + Making sure the “Allow Comments” in the meta box for every post is checked.
    + Temporarily disabling all plug-ins to check if there’s conflict with the comments sections
    + Tried using another theme.

    But all those were unsuccessful.

    The comment box appears on the pages though, but not on posts. When I try to create a new post and when I check the preview, the comment section is also not showing up.But when I try to create a new page, the comment section is present.

    I am at a total lost as to why this is happening since the comment section seem to work on pages but not on posts.

    Any kind of help on this problem would be GREATLY appreciated.

    THANK YOU in advance.

Viewing 10 replies - 1 through 10 (of 10 total)
  • Moderator t-p

    (@t-p)

    If you can, please share URL of a post where comment box is not showing up.

    Hi @t-p ,

    Thank you for your reply!

    Here’s one post not showing the comment box.

    Hoping you can help me on this regard.

    Thanks!

    • This reply was modified 1 month, 2 weeks ago by  apasite000.
    Moderator t-p

    (@t-p)

    Please duble check: To enable comments on future Pages/Posts, uncheck/check “Allow people to post comments on new articles” in Settings -> Discussion.

    Then where you create/edit posts or pages in admin, check if you have ticked comments for your posts/pages in the “discussion” box below the editor. If you don’t see the “discussion” box there, in the ‘screen option’ dropdown field (located near the top right), there are tick-boxes to show the ‘discussion’ box for the posts/pages. Tick mark it. In the ‘discussion’ box below the post/page editor, you can then allow/disallow comments for the page.

    Hi @t-p ,

    I have unchecked and checked the “Allow people to post comments on new articles” in Settings -> Discussion.

    Also double checked that the “Allow Comments” on the posts is ticked.

    The problem seems to persist.

    Any more idea why?

    Thanks so much!

    Moderator t-p

    (@t-p)

    Looks like you removed the post URL!

    Hi @t-p ,

    Oops, I did. Sorry for that. It’s back now.

    Here’s another one. This is a page and if you scroll down to the bottom of the page, you’ll see that there’s a comment section. However, that doesn’t seem to be the case for posts.

    Any ideas please let me know.

    Thanks again!

    Moderator t-p

    (@t-p)

    I recommend asking at https://wordpress.org/support/theme/oceanwp so the theme’s developers and support community can help you with this.

    Understood. Thank you, @t-p!

    Moderator t-p

    (@t-p)

    You are welcome 🙂

    Moderator t-p

    (@t-p)

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Comment section for posts not showing up’ is closed to new replies.