Support » Plugin: GamiPress - PeepSo integration » Comment publication time very long more than 10 seconds

  • Resolved habibal

    (@habibal)


    I have a problem with the comments by activating your plugin the display time passes less than a second to 11 seconds to see appearing the comment is very long.

    I did not notice anything notable on the console

    Peepso updated multisite gamipress up to date

    • This topic was modified 1 year, 11 months ago by habibal.

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Thread Starter habibal

    (@habibal)

    Hello I forgot to write it on the first topic sorry
    After desactivating one by one of the plugins, the problem disappearing by desiable woocommerce!

    would you have an idea of the nature of this white please

    think you

    • This reply was modified 1 year, 11 months ago by habibal.

    Hi @habibal!!

    So if disabling WooCommerce makes the problem go away, the problem is caused by WooCommerce.

    You have to contact WooCommerce support and explain what’s wrong with you so they can fix it.

    Hope it helps!

    Thread Starter habibal

    (@habibal)

    finally it is not a question of woocommerce the cache had distorted the result if we comment line n 27 of the file triggers.php the slowing down disappear. the inscription in the log?

    my cache is desiabled now

    // 'gamipress_peepso_new_activity_comment' => __( 'Write a comment on an activity post', 'gamipress-peepso-integration' ),
    my client must have a finished product I hook while waiting but it’s temporary
    you have an idea ?

    List of plugin install on the main site:
    Customer Reviews for WooCommerce
    affiliate-wp
    Elementor
    Elementor Pro
    GamiPress
    GamiPress – AffiliateWP integration
    GamiPress – Email Digests
    GamiPress – LearnDash integration
    GamiPress – Paid Memberships Pro integration
    GamiPress – PeepSo integration
    GamiPress – Progress Map
    GamiPress – WooCommerce Discounts
    GamiPress – WooCommerce Partial Payments
    GamiPress – WooCommerce Points Gateway
    GetResponse for WordPress
    Query Monitor
    Shortcodes Ultimate
    The Events Calendar
    Themify – WooCommerce Product Filter
    UpdraftPlus – Sauvegarde/Restauration
    WooCommerce
    WooCommerce Stripe Gateway
    WP Light Tours Builder
    WP WC User Registration
    WPC Frequently Bought Together for WooCommerce
    Yoast SEO`

    • This reply was modified 1 year, 11 months ago by habibal.
    • This reply was modified 1 year, 11 months ago by habibal.

    Hi @habibal !

    Is possible that GamiPress can slow down some process if you have configured several awards.

    For example, the LearnDash integration includes several events based on the quiz completion (if a user completes it, if pass or fails, if a user has completed it with a minimum grade, etc).

    If you configure 20 requirements (points awards, deducts, steps, and rank requirements) it could make the process slow down since GamiPress needs to check if a user is able to earn all of them and also if the user should earn something more (like an extra achievement, or award extra points for something, etc).

    For that, the way you can speed up some process is by reducing the number of requirements that are using this event (for example, if you have 20 achievements looking for the same event, reduce them to 10).

    The GamiPress awards engine is developed to run as fast as possible but is comprehensible that will run slower if is required to perform several checks on a single action.

    There are some improvements you can apply to your database and server but these recommendations are outside the GamiPress support since they are related more to server management and improvement than to GamiPress.

    Please, make them on a staging site first and always consult them to your hosting provider first:

    1) Check all our guidelines about database performance as explained here: https://gamipress.com/docs/advanced/database-performance/
    Note: If you are not sure how to apply them, contact to your hosting provider and send them this document to check this for you.

    2) Clean up GamiPress “Event Trigger” logs from GamiPress -> Tools -> General -> Clean-Up Logs Tool.

    3) Remove the GamiPress points awards or achievements and ranks requirements you don’t truly need (to reduce the number of awards).

    4) Enable Memcached on your server (talk with your hosting team support).

    Hope it helps!

    Thread Starter habibal

    (@habibal)

    It was necessary to reinstall the plugin and reset all the data, it he actually acts the heaviness of the Gamipress table and the Heartbeat too frequent.

    Plugin Author Ruben Garcia

    (@rubengc)

    hi @habibal

    GamiPress does not have anything related with the WordPress hearbeat and there are plugins on WordPress to modify its workflow

    For slow downs, check what mentioned @pacogon about setup multiples requirements because with an incorrect configuration you can overload your server

    Hope it helps!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Comment publication time very long more than 10 seconds’ is closed to new replies.