Support » Fixing WordPress » Comment posted to wrong blog post

  • Resolved coennaninck


    Dear WordPress community,

    My website allows people to post comments without a registered account, but I would like to change this to have people register for an account in order to comment. The problem I face however is that when I enable this on my website every time a registered user posts a comment, the comment is posted to the wrong blog post, that specifically being the very first blog post I ever published, instead of the one the commenter commented on.

    I have Googled this problem without having found a solution. I have contemplated reinstalling WordPress, but my website has so much customizations (contact forms I can’t export, widgets, custom CSS, etc.) that I rather see if it can be fixed manually.

    I think something may have gone awry with an update.

    Hopefully someone can help with me with this problem.

    My website is: and the blog is:

    By the way this did not work for me:

Viewing 3 replies - 1 through 3 (of 3 total)
  • coennaninck


    I fixed this problem just now. For anyone in the future finding this post through a search engine or something, here’s how solved this:

    1. First back up your entire site so if something goes wrong you can restore it with one click.
    2. Make sure your site is updated to the latest version of WordPress (not a beta release).
    3. Log in to your FTP containing your WordPress site.
    4. In the root directory (usually public_html) delete the wp-admin and wp-includes folders in their entirety (meaning the two folders and all of the folders and files they contain). DO NOT delete the wp-content folder.

    5. Download the latest version of WordPress from, unzip the file, browse to the wordpress folder in it, and then copy wp-admin and wp-includes over to your public_html folder.

    This fixed it for me.



    Well, I spoke too soon. This didn’t fix it for me. I thought it was fixed but it happened again later. As soon as I tick Settings > Discussion > Other comment settings > Users must be registered and logged in to comment then the issue starts.

    I’m going to backup my data and reinstall WordPress, then import my posts and settings. I’m glad that the menus and such are also exported by WordPress’ Export feature, even Contact Form 7 forms are exported. For widgets there is a plugin available:



    I found out what is causing this issue, but I don’t have a solution yet. So I’m just posting this here if anyone will ever run into this problem.

    I did as I mentioned in the previous post, just basically reinstalled everything (deleted both WordPress files from server (everything, admin and content) and also deleted the database. Then created a new database and imported my posts, settings, widgets, the works, including the general settings not saved by the WordPress exporter (saved those in screen captures).

    Long story short, the Jetpack plugin is causing this bug, because when I turn it off the issue goes away.

    I know no one’s going to comment on this post because probably no one has run into this issue, and/or doesn’t have a solution, but just in case anyone ever does, my solution is to disable the Jetpack Commenting plugin, but keep everything else from Jetpack on.

    I have reply notifications for this thread on, so I will be notified if anyone runs into this and has a solution; so if you have one, please share so I can enable this Jetpack feature in the future again.


Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Comment posted to wrong blog post’ is closed to new replies.