Support » Plugin: Better Notifications for WP » Comment notification to author only with “not logged in” commenters?

  • Resolved newslicer

    (@newslicer)


    Hello Team,

    first of all: your plugin is just amazing. It’s without any doubt the best out there for WordPress. I love it <3

    The “Comment notification” for authors works great and gets triggered every time a (not logged in) guest user of my blog (on my blog anyone can comment) comments a post. And email notification gets delivered to the author and everything is fine.

    I also have subscribers in my blog. When a subscriber logs in and comments on a post there is NO email notification delivered to the author.

    Is this something which can be configured?

    Kind regards from Germany

    Andre

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author bnfw

    (@voltronik)

    Hi @newslicer,
    Thanks for your message and kind words.

    So when a non-user posts a comment, the notification is triggered but when a registered user in the subscriber role posts a comment, the same notification is not triggered – is that correct?

    newslicer

    (@newslicer)

    Hello 🙂

    That’s absolutely correct. Exactly that’s the problem.

    Kind regards

    Andre

    Plugin Author bnfw

    (@voltronik)

    Hi @newslicer,
    I must have missed your reply.

    Let me investigate and see if I can replicate this at my end.

    newslicer

    (@newslicer)

    Hello @voltronik,

    ok, thank you! The issue is still relevant.

    Kind regards

    Andre

    Plugin Author bnfw

    (@voltronik)

    Hi @newslicer,
    Thanks for bearing with me.

    I’ve just tested this but it triggers a notification for me both when a user is logged in and not logged in.

    The only settings I have checked in Settings > Discussion are:

    – Allow people to post comments on new articles
    – Comment author must fill out name and email
    – Enable threaded (nested) comments [2] levels deep (to enabled Comment Reply notifications)

    I also have comments enable for the post in question.

    Can you confirm this is how you have the above set-up along with using the latest versions of WordPress and BNFW?

    Hi @voltronik,

    thanks a lot for your test.

    I have all the same setting as you. Maybe any other / advanced setting is in our way. I made a screenshots of my discussion settings. You may find the file under this link:

    WordPress Discussion Settings

    My WordPress is 5.2.2. BNFW is 1.7.3.

    Any post on my page can be commented.

    If it works on your side, we will find the solution.

    Kind regards

    Andre

    Update!

    I just saw that I ticked the box “Do not send this Notification to the User that triggered it” in my comment notification of BNFW.

    So sorry. I unticked the box and guess what: it works!

    I apologize for the circumstances.

    Thanks again for this really great plugin!

    Andre

    Plugin Author bnfw

    (@voltronik)

    Hi @newslicer,
    Not a problem – glad you got it sorted!

    If you like BNFW and the support, please feel free to leave an honest review.

    Thanks @voltronik!

    I left you a review.

    Plugin Author bnfw

    (@voltronik)

    Wonderful, thank you!

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.