• BitEdge

    (@whatwhatwhatwhat)


    Hi guys,

    I only want this plugin to allow users to subscribe to a mailgun email list from my site https://www.bitedge.co/ I would rather it did not send emails from my site.

    Anyway I am not receiving comment notification emails even though I have
    > Email me whenever A comment is held for moderation
    > Email me whenever Anyone posts a comment
    Both checked in the settings discussion section. My host tells me this is what happens when a user makes a comment.

    `
    Part of the Exim server’s logs below:

    Code:
    2017-02-16 03:01:19 TLS error on connection from so254-6.mailgun.net [198.61.254.6]:64308 (SSL_accept): error:00000000:lib(0):func(0):reason(0)
    2017-02-16 03:01:19 TLS client disconnected cleanly (rejected our certificate?)
    2017-02-16 03:01:19 SMTP connection from so254-6.mailgun.net [198.61.254.6]:64308 closed by EOF
    2017-02-16 03:01:19 SMTP connection from [198.61.254.6]:38500 (TCP/IP connection count = 1)

    Each time a comment is posted on the website, this is recorded in the logs. This leads me to believe there is either an issue with the website’s email configuration or the necessary outbound connection is not allowed.
    `

    I tried changing the mailgun plugin settings from HTTP API to SMTP both secure and insecure but that did not seem to work either.

    How can we get these comment email notifications working and still have the subscribe to maillist function?

    Cheers

    • This topic was modified 7 years, 3 months ago by BitEdge.
Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Mailgun

    (@mailgun)

    @whatwhatwhatwhat Does the plugin give you any sort of error when using the HTTP API?

    Thread Starter BitEdge

    (@whatwhatwhatwhat)

    Not that I see. If you mean in the server’s log the above lines that I pasted from the log are when we had HTTP API selected in the plugin.

    Plugin Author Mailgun

    (@mailgun)

    @whatwhatwhatwhat According the Mailgun logs, we are receiving the comment emails fine, but the delivery to your Exim mailserver at bitedge.co is failing.

    In the initial log you have provided, it appears that our delivery systems may not be completing the delivery to your MTA because of an SSL/TLS certificate issue.

    Try disabling certificate verification on your Mailgun domain control panel under the Security Settings header.

    Thread Starter BitEdge

    (@whatwhatwhatwhat)

    Hi, that did not help unfortunately.

    Thread Starter BitEdge

    (@whatwhatwhatwhat)

    I just realised this also means I am not getting contact us submissions made through contact form 7 plugin here

    https://www.bitedge.co/contact-us/

    despite the plugin outputting

    Your message was sent successfully. Thanks.

    Would these message that I have missed be accessible through mailgun or site ligs?

    Thanks

    Plugin Author Mailgun

    (@mailgun)

    @whatwhatwhatwhat The plugin is sending correctly, but your MTA (exim) is not receiving the mail correctly. I believe you may have an issue with certs on your mail server, which may be resolved by upgrading the CA certs on that machine (ca-certificates package on Debian-based distributions, etc). To test this, you should disable certificate verification on Exim (Exim TLS docs here) and then try to send an email to yourself through the plugin.

    Regarding viewing messages through the control panel: You can view message content for up to three days after it passes through Mailgun. You can see how to do that here.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Comment notification email are not being sent’ is closed to new replies.