Support » Fixing WordPress » Comment moderation oddness

  • Currently running WordPress version 1.5-gamma 2005-02-05, slightly modified version of the new default template.

    Noticed this behaviour yesterday and today:

    Enter a new comment.
    Comment immediately appears on the single post page, but count of comments above it does not increment, and neither does the number on the index page.

    On going into admin (or on getting the notification email), I find that the new comment is in fact awaiting moderation. If I approve the comment, the comment counts increment as normal.

    Just wondering why the comment is appearing before approval. Is it a bug, or have I broken something?

    This is happening on my test site here (the site linked from my name is still running 1.2.x)



Viewing 13 replies - 1 through 13 (of 13 total)
  • Moderator Michael Adams (mdawaffe)



    This is a new feature. The idea is that the commenter knows that a comment has been posted, but it won’t be shown to anyone else until it’s been moderated.

    It really should say next to it “IN MODERATION”, or something, though. I can see some pretty annoying discussions on someone’s blog otherwise: “Did you not READ my comment? It’s right there! ******”.

    Ahhhhhhhhhh!!! Thanks 🙂

    Now that makes sense. Avoids commenters reposting 16 times because it doesn’t show up immediately.

    I’m inclined to agree about the “in moderation” or somesuch label, though.

    It does show “in moderation” but on in IE. If you are using IE, you will see your comment and then it will say “Your comment is being held for moderation,” so at least you know.

    FireFox does not show the “Your comment is being held for moderation” statement. I’m currently trying to figure out why. Anyone else?

    It does show the ‘held for moderation’ for Strayhorn using Firefox. The string is displayed as per comments.php if using the default theme:

    <?php if ($comment->comment_approved == '0') : ?>
    <em>Your comment is awaiting moderation.</em>
    <?php endif; ?>
    If you’re still using a pre-release version, or the Classic theme, you may not see this.

    <?php if ($comment->comment_approved == ‘0’) : ?>
    (Your comment is awaiting moderation)
    <?php endif; ?>

    That’s what I have in my comments.php file, but I am still not getting the comment moderation statement to show up in FF. It shows up if you try to comment on my site with IE.

    I also just tried putting the default comments.php page back up to see if that would force the moderation statement to show, but it doesn’t. I am thoroughly stumped.

    I just tested and not only do I not get the moderation message at your site, but I also don’t see my comment….using FF.

    Right, you won’t see it because it went into moderation and I have to approve it before you post. Once I approve it, it will show up. The thing is, the comment is *supposed* to show along with the moderation message. I’m not sure why this is happening. It works that way in IE, but not in FF. I’ve tried everything I can think of and nada.


    I actually just figured this out. Since I turned my own layout into a theme, I thought I had to upload the comments.php page into my theme directory. Which in theory worked, but then the above problem happened.

    I deleted my tweaked version of my comments.php page and noticed that the page was still loading from somewhere. After some troubleshooting, I found that my theme was pulling the comments.php page from the “default” theme directory. After re-uploading my own tweaked version of the comments.php page to the “default” theme directory, my test comment that I posted now shows up in FireFox with the statement that it is being held for moderation.

    And to think I worked all day on this and badgered ColdFusion as well. *shakes head* Many thanks to CF and everyone else who attempted to sort this out with me. I REALLY appreciate it!

    Could you paste this line of code in the classic comments template too?

    the comment moderation isn’t working on my site i installed it via Fantastico

    This problem sounds very similar to side-effects of the “login-changes-site-url” woes that plagued WordPress a while ago. More specifically, the “Edit this” buttons would disappear in Firefox, but not in IE.

    If that’s the case, then the problem is a conflict with cookies that WordPress sets in Firefox vs. those it sets in IE. I think it might have something to do with having a different WP address than the WP blog URL.

    I think this bug is ready for the mosquito.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Comment moderation oddness’ is closed to new replies.