Support » Fixing WordPress » Comment Links and Stand-Alone Post links not working

  • Resolved sassy007

    (@sassy007)


    I know they were working within the past week.
    Yesterday, when I checked, they had stopped working (lead to my 404 error page).

    I checked with my webhost(surpass hosting) and they say that the problem lies within wordpress.

    Any suggestions?

Viewing 15 replies - 1 through 15 (of 19 total)
  • Try re-setting you permalinks and, eventually, re-create the .htaccess rules.
    Without permalinks it works: http://www.pileofsassy.com/index.php?p=15

    Unfortunately I have no idea how to do anything that you said.

    I’m an incompetent wordpress user. :/

    hmm… none of my “categories” are working, either – I didn’t do anything, I swear!

    sass, if you really did nothing, then I guarantee you it IS something your host did. Ask them if they “upgraded” ANYTHING…. php? mysql? apache itself? cpanel?

    Ok I just replied to them AGAIN asking if anything was upgraded.

    Well, let us know what they say when you hear from them…. meantime, go back over anything you MIGHT have done in the last week, but forgot about due to the press of other RL stuff….

    The only thing I can think about is that I changed my hotlinking protection to allow a site to hotlink to me – that’s it.

    I’ll definitely let you know when I hear back – thanks for your help!

    and, changing the hotlinking protection affects the .htaccess file. hmm.

    This is the last I heard from my webhost:

    “I checked your wordpress admin panel. I cannot find anything on the server that would be affecting this. I am not sure what permissions wordpress requires, or what files it uses when loading the comments page. I noticed you get this message also when looking at archived posts, so you may be missing whatever file it needs. Unfortunately we can’t provide further support for third-party applications, so I suggest either making a backup of your database and trying a fresh install, or checking the wordpress support forums. Let us know if there is anything we can do to help.

    Thanks,
    R***”

    Well, thing is, if you did nothing for sure, WordPress does nothing on its own, y’know?

    So yeah, I’d be looking at the hotlinking stuff, because that’s added into the .htaccess. And if you already have permalinks for wp, there might be something wonky going on there.

    I’d recission the hotlinking to see if having it out of the way fixes the problem. If so, I’d tell my friend they’d have to do something else….

    sassy,
    who did install WP for you? Who did set up the permalinks? Because you said you don’t understand what I suggested as a simple check and solution.
    Go to admin panel > Options > Permalinks and empty all the fields (=delete everything from the fields) and click the Update settings button.
    Check if everything works. Post back here 🙂

    Oh my gosh I think I fixed it!

    I pasted the info at the bottom of the permalinks page into my .htaccess file and I think that did the trick…
    I can see my comments pages now…
    Did I do it right?

    I installed WP and set up permalinks, but I guess I’m still not very WP savvy.

    My categories links still aren’t working, though – any tips for that?

    and my monthly archives still aren’t working, either. drat.

    OK, I give up…

    awww no giving up!
    Sad.

    Ok weird.

    It stopped working and then started working again.

    Categories are working now as are monthly archives.

    So weird!

    Eh, well, don’t look a gift horse in the mouth, sweetie! Thank whoever, and enjoy….

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘Comment Links and Stand-Alone Post links not working’ is closed to new replies.