WordPress.org

Support

Support » How-To and Troubleshooting » Comment Links and Post topic link not working

Comment Links and Post topic link not working

  • Hi, I’m new to wordpress…and I’ve searched this problem and been unable to find an answer.

    My comment links and the link to the title of the post (where it would open up its on page) both seem to link back to the front page – instead of going where they are supposed to go.

    If I scroll over a comment link on the front page, it will give me something like this: http://realitynewslive.com/?p=7#respond

    but when I click on it, it goes back to the main page.

    Same w. post topics.. If i put my cursor over the post topic, I get something like this : http://realitynewslive.com/?p=10

    But if I click on it, it just goes back to the front page. How do I correct this?

    Thanks in advance for your help.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Hi,

    I went to the site and both the comment link and the link to the title of the post worked fine for me.

    Maybe try it again? Scroll down when you try it, too. It might look like it’s on the front page but the page really is different–it’s just that the design stays the same. But if you go to the bottom of the post it will look different.

    This is exactly what’s happening in my WordPress as well! And I did check carefully as amynelso instructed, and no the comment and post topic links did go to front page instead of going to where it’s directing to. I could’nt figure out what is going on!!! Please help~~

    I’m having the same problem as well! I don’t know what the problem is. =*(

    I am experiencing the same problem too. Can someone please provide some guidance or troubleshooting tips regarding this topic?

    My blog is http://www.abovethefolddesign.com/blog

    So, apparently there is a problem with the ‘Date and Name Based’ permalink syntax (e.g. /blog/index.php/2007/09/21/sample-post/). When I use the default permalink syntax, then I don’t experience any problems. The problem is that WordPress is not writing the necessary rules in my .htaccess file to translate the “Date and Name Based” permalink structure, even though the file permissions on the .htaccess are set to 660.

    Does anyone know what the rewrite rule is for the “Date and Name Based” permalink structure? I want to try and add it into the .htaccess manually and see if it fixes the problem.

    For those folks that are experiencing a similar problem, take a look at this support page to isolate and troubleshoot your problem: http://codex.wordpress.org/Using_Permalinks

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Comment Links and Post topic link not working’ is closed to new replies.
Skip to toolbar