Support » How-To and Troubleshooting » Comment link not working!

Comment link not working!

  • It looks like it is posting the URL for the comment link twice. If you hover over it, you can see this. Can anyone help me? Thank You!

Viewing 14 replies - 1 through 14 (of 14 total)
  • Same thing with your permalinks.

    Maybe double check what you have the URI options set as?

    It’s doing it with your permalinks, too.

    Check your general options and make sure that these are correct:
    WordPress address (URI):
    Blog address (URI):

    If that isn’t the problem, in your Main Template make sure that you don’t have your website address in front of the comment and permalink code. In other words, for the permalinks for example, you want to have

    <a href="<?php the_permalink() ?>


    <a href="http://mytwistedlogic.com/<?php the_permalink() ?>

    In options they are both listed as
    nope, its not that….

    <?php get_header(); ?>

    <!-- begin content -->
    <div id="content" class="narrowcolumn">

    <?php if (have_posts()) : ?>

    <?php while (have_posts()) : the_post(); ?>

    <div class="divTitle1">
    <div class="divTitle3"><span class="titolino"><?php the_title(); ?></span>
    Posted on : <?php the_time('F jS, Y') ?> @ <?php the_time('g:i a'); ?> by <img src="images/name.gif" alt="name" title="name"/> </div></div>
    <div class="post" id="post-<?php the_ID(); ?>">
    <span class="pside">Admin :</span><?php edit_post_link('Edit the post.','',''); ?>
    <span class="pside">Post category :</span> <?php the_category(', ') ?>
    <span class="pside">Link to post :</span> ">permalink
    <span class="pside">Comments :</span> <img src="/images/speechbubble.gif" alt="speechbubble" title="speechbubble"/> <?php comments_popup_link('No Comments', '1 Comment', '% Comments'); ?>
    <div class="entry">
    <?php the_content('Read the rest of this entry »'); ?>

    <?php comments_template(); // Get wp-comments.php template ?>

    <?php endwhile; ?>

    <div class="navigation">
    <div class="alignleft"><?php next_posts_link('« Previous Entries') ?></div>
    <div class="alignright"><?php previous_posts_link('Next Entries »') ?></div>

    <?php else : ?>
    <div class="box">
    <h2 class="center">Not Found</h2>
    <p class="center">Sorry, but you are looking for something that isn't here.
    <?php include (TEMPLATEPATH . "/searchform.php"); ?>
    <?php endif; ?>

    <!--end content -->

    <?php get_sidebar(); ?>
    <?php get_footer(); ?>

    Should I try reuploading the file???

    ~Gotta read closer before I reply… ~


    Please do not (1) double post http://wordpress.org/support/topic/42407 or (2) bump so quickly.
    Everyone posting here has something they need help with.

    Actually the category links and the calendar are off too.

    Are you positive that the URIs are exactly as you posted?
    Do you have anything set up in the Permalinks?

    Do you have your install in a pics folder? The category links to go to/pics/category and they work.

    pics folder? nope…


    Under the main directory (wordpress) create “.htaccess” file and add “DirectoryIndex index.php” to it.

    Looks like she started over.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Comment link not working!’ is closed to new replies.