[resolved] comment issue - about to throw myself out of the window! (4 posts)

  1. mariehdb
    Posted 7 years ago #

    Ok I have this problem with my online blog, my local testblog installed on Mac OS X.5 in French and another testblog installed on Win XP in English so I guess it's not coming from me.

    The comment author names won't link to the URL the author has given. When you install wordpress, there is a fake comment from 'MR WordPress' and his name links to an URL but on any new comment won't link to anything.
    The readers on my blog are complaining about that and I don't know where to look for the solution anymore!
    I have tried changing the template, it doesn't help.

    Idea, anyone??

  2. justinratwebtek
    Posted 7 years ago #

    Now don't throw yourself out the window, you'd have to pay for it then...

    I'm curious what your comments.php file (the template version) has for the link, since you're running a customized version of the Sandbox theme (I downloaded 1.2 to make sure it included the link). Make sure you have:


    in that file. The original block looks like:

    <li id="comment-<?php comment_ID() ?>"
    class="<?php sandbox_comment_class() ?>">
    <div class="comment-author vcard"><span class="fn n">
    <?php comment_author_link() ?></span></div>
    <div class="comment-meta"><?php printf(__('Posted
    %1$s at %2$s <span class="meta-sep">|
    </span> <a href="%3$s" title="Permalink to this
     comment">Permalink</a>', 'sandbox'),

    If all of that is there, then have you attempted to disable any plugins that interact with the Comments to see if there is something else interacting with it all?

    (edited to format code)

  3. mariehdb
    Posted 7 years ago #

    Thanks so much for answering!

    The comments.php file in the sandbox theme does not look like this AT ALL. And now something new: you can't post comments anymore, various error messages are appearing.

    I think I am just going to backup my database and reinstall wordpress from scratch, or at least the whole WPcomment folder, and also inactivate the Gravatar plugin.

  4. mariehdb
    Posted 7 years ago #

    OK, I reinstalled WordPress, now everything works fine under Kubrick and with no plugin. I'll just have to take one step at a time with my new trials, I guess.

    Thanks for the help.

Topic Closed

This topic has been closed to new replies.

About this Topic