Support » Plugin: Anti-spam » Comment is a spam message always

  • taisa1984

    (@taisa1984)



    Hi! I am having problems with the plugin, now everytime someone tries to comment, it says “Comment is a spam”.

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author webvitalii

    (@webvitaly)

    Hi Taisa,

    I see at least two issues with the current theme:

    1. It does not have proper wp_head() function. Without it Anti-Spam plugin does not able to include js file via wp_enqueue_scripts hook.
    2. It does not have proper comment_form hook in the comments form. Without it Anti-Spam plugin does not able to add proper hidden input fields to work properly.

    You can see how this is done in any WordPress default theme.
    Anti-Spam plugin works well with default themes and with most of the themes which have two hooks I mentioned above.

    taisa1984

    (@taisa1984)

    Oh! Thanks. I will send this info to the theme developers.

    Sorry to report but I’m having exactly the same problem. Theme is Storefront, but I keep getting ‘Comment is a spam’ message. Have no choice now but to deactivate the plugin.

    Plugin Author webvitalii

    (@webvitaly)

    Hi @patboran

    I just tested the Storefront theme and Anti-Spam plugin works good with default comments section.
    Can you try without any plugins installed (and being logged out) if it is working?
    If it is working – you may try to enable plugins one by one to find what might cause the issue.

    Thanks for your prompt response. I’m not sure I can deactivate all plugins on my site (and break its core functionality) but I will try to clone to a dev site and see how it goes there. Many thanks in any case. I’m sure it happens that a random combination of other plugins can cause unpredictable interference

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.