Support » Fixing WordPress » Comment in wp_comments cannot be displayed

  • sherwood


    this is default 1.2.2 install, up and running, trying to add comment. after I submit the comment, text was saved to wp_comments table, I can view them from SQL. But the WP page always display “no comments”.. what to look for?

    p.s. also tried move a working 1.5-beta WP, it was working with its own DB, but once I use upgrade option to move from 1.2.2 to 1.5, 1.5 WP comments won’t display either.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Moderator James Huff


    Volunteer Moderator 🚀

    Login to your WP admin interface and go to Edit/Awaiting Moderation. If your comments are there, they were caught in the moderation que. This means that you have either posted a comment containing a word in the blacklist at Options/Discussions, or that your blacklist has a blank line or / character in it.



    Also double-check those “Before a comment appears” settings under Options > Discussion.



    problem solved.. thanks Kafkaesqui and macmanx for your help! this is a great community

    I’m a long time wordpress user. Starting just today, I am no longer able to get a comment posted to my site. What is going on?

    I’ve looked at the above and I don’t have any such issue. Any further help would be much appreciated..

    Not just at work, but at home also. Not only that, but also from a remote desktop connection eight states away. Not even the tech support guy from could post a comment.

    What’s going on here. I dare you to try posting a comment at It just doesn’t work.

    The only thing that does work is if I LOGIN as myself, then I can post a comment, but it still takes about a minute and a half.

    But if I log out, NOTHING!!!!

    Please tell me there is a fix for this!!!

    cliffeotc: please don’t double post on non-relevant topics….

    And please be patient: anyone who might be able to help you here is a volunteer. Depending on where in the world you live, it might be as much as 12 hours at minimum for someone who has some information to help you to see your post and reply.

    If you have done NOTHING to change your setup, then most logically, your host has “upgraded” something. Check with them.

    jaseone Says: Your comment is awaiting moderation.
    October 14th, 2005 at 11:53 pm
    Just testing comments.

    Have you changed anything in Options / discussion lately or installed any plugins? You should see your comments to moderate under Manage / Awaiting Moderation.

    BTW… Yes, I had changed a lot of settings in options/discussion since this started happening. Trying to fool around with everything to get this to work. The one thing that I unchecked overnight was the blacklist button at the bottom. So today, I see that it posts and I went back and checked that option again and it posts with it checked now too.

    So now I’m back to my original option settings before I started having this problem. Now it does seem to work…

    Comments were not going to moderation yesterday. Well 1 out of 20 would make it, the rest simply did not show up anywhere. The comments-post.php would simply time out. Today, it is actually refreshing and posting the page with the commment in moderation… HOWEVER… it’s taking 20 to 35 seconds to post.

    With it taking about 35 seconds to refresh, is it not possible that some browsers will eventually time out still?

    Is there a reason for this to take so long…?

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Comment in wp_comments cannot be displayed’ is closed to new replies.