Support » Fixing WordPress » Comment date format

  • Resolved Dkersys



    I’m recently translating wordpress in Lithuanian language and I have a problem with comments.

    This is an image in case of lack of information.

    As you can see, I’ve translated almost everything. Also, this theme supports translation function. But it’s not useful from my view because my language has about 12 different word endings. So, I just want to create this type of format: Y, m j(d.) | G:i
    I’ve searched in single.php, which redirected me to wp-includes/comment-template.php. From there I’ve translated a bit more but still I couldn’t do anything about the date format.

    I really hope to get some fast help. Thanks for reading!

Viewing 3 replies - 1 through 3 (of 3 total)
  • what theme are you working with?

    it might have a comment-callback function in functions.php, where you might find the comment code.


    I changed
    <span class=”name_f” > <small>(<?php if(!function_exists(‘how_long_ago’)){comment_date(‘M d, Y’); } else { echo how_long_ago(get_comment_time(‘U’)); } ?>)</small></span>


    <span class=”name_f” > <small>(<?php {comment_date(‘Y, m j G:i’); } ?>)</small></span>


    Silly me, I had to clear cache. It worked! Thank you very much 🙂

    I am also using widezine
    I have changed the time format setting for the site , and its fine all over the site except in two places.

    1- comments…I would also love my choice intesad of “xx ago” and this post should solve this
    Dkersys, in which file did you make the change ?
    I did not find any “how_lon_ago” in comments_template.php or in functions.php

    2- in archives (or category pages) …. where the time format has not been updated with my preference… any idea on which file should be amended?

    thank you for your help

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Comment date format’ is closed to new replies.