Support » Plugins and Hacks » Comment form still not working, and how do I log in?

Comment form still not working, and how do I log in?

  • I just updated to 1.9.7, but the comment form still isn’t working – I keep getting the following error:

    There was an error posting your comment. Maybe it was too short?

    Also, how on earth do I log in? I can enter my username and password, but where’s the submit button?


Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author BraveNewCode Inc.



    Please update to the latest version (1.9.7). It includes a fix for the issue you’re describing. Let us know if you have further questions.

    Also, how on earth do I log in? I can enter my username and password, but where’s the submit button?

    You can use the “Go” or “submit” button on your device.

    As I stated clearly in my first sentence, I did update to 1.9.7.

    So what would I press to log in on an iPhone?


    also i installed the new release of the plugin yesterday but i have the same result.

    Accessing from my IPHONE i receive the message ” comment is inserted” but really the comment is lost.

    All work correctly if i put the plugin in disabled mode or switch my IPHONE in standard mode using the switch ON-OFF of plugin.

    I want inform you that all users that have this problem are already authenticated.

    It seems the comments.php command is searched on the URL and not in the SITEURL.

    Thank you so much for your help.

    Plugin Author BraveNewCode Inc.


    @ljmac – On the iPhone, press the “Go” button after entering your username and password.

    @claudio58 – We’re aware of the issue and will be addressing in a later release soon. Thank you for your patience.

    When is this bug going to be fixed? I just tried the commercial version, and found that comment posting does work on that version. However, I found that 3.0.6 has other bugs, and I prefer the look and functionality of the free version.

    It would seem that this bug should be easy for you to fix – just port the comment posting code from the commercial version to the free version.

    Plugin Author BraveNewCode Inc.


    Hi ljmac,

    If you haven’t already, please check if another one of your active plugins is conflicting with WPtouch by deactivating the other plugins briefly one at a time and see if you find a culprit.

    The thing is, WPTouch 3.0.6 works just fine with exactly the same set of plug-ins. So you already know how to code a working, compatible comment form – once again, just port your comment form code over from version 3, and it should work.

    Plugin Author BraveNewCode Inc.



    It is not as trivial as it may seem and it’s not a simple copy/paste job.

    See my post here:


    And this one from another user confirming my suspicions:


    It seems the issue is that WPTouch assumes the user’s WP is in the root, so if it is in a subdirectory, commenting and logging in don’t work. This actually should be a very simple problem to fix (you just have change your static URL references to the dynamic references you should have used from the beginning), and is a very basic coding error.

    Plugin Author BraveNewCode Inc.


    To be clear, the free version of WPtouch and WPtouch Pro are different plugins rather than one being an extension of the other with added features. WPtouch Pro is built differently to accommodate advanced desktop theme functionality such as custom post types, custom page templates, and shortcodes. The solution you propose, while seemingly simple to implement, in this scenario requires more extensive development. Thank you for your suggestions. We do take each into consideration when developing future release of both free and Pro versions.

    Forget about WPtocuh Pro – this is just basic WordPres coding practice. You must not use hardcoded URLs – they must always be dynamic. It is very common for people to install their WordPress in a subdirectory, even for basic sites.

    Also, my solution would be very simple to implement, as I could do it myself, but the problem with that is that every time I update the plug-in, I would have to re-apply my hack – a fix that you should apply yourself.

    Is there anybody else I can talk to about this who knows anything at all about WordPress coding? This really is a very simple fix – once again, I can tell you how to do it.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Comment form still not working, and how do I log in?’ is closed to new replies.