Support » How-To and Troubleshooting » Comment form not appearing

Comment form not appearing

Viewing 15 replies - 1 through 15 (of 17 total)
  • Justin Tadlock


    WordPress God

    Do you have this line in single.php?

    <?php comments_template(); ?>

    If you don’t, add it after The Loop.

    Yeah, it’s in there. Any more advice?



    Forum Moderator

    Does your theme include a file called comments.php?

    Yes. Could it be a CSS issue?



    Forum Moderator

    No. I’ve looked at the source markup on your single post pages and there’s definitely no comment form being generated.

    Am having the same problem myself with http://www.garethstravels.com

    Have tried four different themes, and none of them show the comments form. This includes the “standard” wordpress theme.

    Comments are turned on both in the “Discussion” settings and on the post itself.

    The source code doesn’t show up the comments form either, so it seems like it’s not being generated by the PHP. The <?php comments_template(); ?> code is there in all the templates.

    I’m running five other WordPress blogs, and none of them have this problem.

    Any ideas?

    No fix for this, but a total reinstall of WordPress resolved it. I copied the themes and plugins straight from the old to the new, and exported then imported blog entries, so none of them were the problem.


    I’m having the same issue. I’m not using the blog as the home page, but don’t know if that’s a issue because I have another site that’s like that with no problem. the comments_template line is on the single.php page as well. Here’s the link if anyone has any ideas:


    I have this problem too, and I’ve tried several different themes, plus installed a completely new copy of wordpress, using a new database, and in a new location (was /wp, is now /omb). The comments form does not show up on the permalink page (using single.php), and I would never have noticed (not being one to get a lot of comments usually) if a new reader had not remarked that she couldn’t find where to put a comment.

    I have <?php comments_template(); ?> in the template and a comments.php file, and I’ve had various problems with wordpress over the years but never one like this, and it is driving me insane that I can’t fix it.

    Additionally, the “more” tag doesn’t work – it shows up but when you click it to go to the permalink page, it also has the “read more” link and nowhere does the full text show up. This is also driving me insane.

    I want to concentrate on producing content, not spend entire days weeping with frustration.

    edit to add my url: http://orangemoon.cbd-hosting.net/omb

    Has anybody figured this problem out yet? I’ve tried hardcoding the comments code into the single.php page, which surely should force it to show up??? I did disable all my plugins previously but it made no difference at all. I’m really at my wits end with this 🙁

    I had the same problem on a site using the Thematic parent theme. Reinstalling WordPress did not resolve. To fix, I edited the following line from \wp-content\themes\thematic\page.php

    <?php if ( get_post_custom_values('comments') ) thematic_comments_template() ?>

    I simply removed the IF logic the author had in there and that fixed the problem. New code:

    <?php thematic_comments_template() ?>

    I’m not sure if there’s a flaw in the logic, but the page now displays the comment form based whether I check Edit Page > Discussion > Allow Comments. Hope this helps.


    I had the same issue when updated the theme on my site. Go to Admin > Settings > Discussion and see if you have enabled the “Automatically close comments on articles older than …”
    In my case this setting was the culprit.

    had a similar problem and this fixed it.


    Thanks for the link vdsn. I am just not clear on where exactly to put the code that Innovine talks about:


    This seems to be fixed by using:
    <?php query_posts($query_string.”&showposts=10″); ?>

    Could you please let us know?


    I looked into it a bit further. It appears to me that this fix only applies to Innovine’s particular code and Theme.

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘Comment form not appearing’ is closed to new replies.