Support » Accessibility » Comment form label missing

  • When using an accessibility tool such as WAVE, the ‘Post Comment’ button within the comment form (which appears to be a part of WordPress Core) is missing a form label and is being flagged as an accessibility issue. Will there be an update for this?

Viewing 3 replies - 1 through 3 (of 3 total)
  • Moderator t-p

    (@t-p)

    I recommend asking at your theme’s support so the theme’s developers and support community can help you with this.

    Thread Starter shanemery

    (@shanemery)

    I did, and they said that the comment form is part of WordPress core, and not something their themes alter.

    • This reply was modified 2 months, 2 weeks ago by shanemery.
    Moderator t-p

    (@t-p)

    This may be a plugin or theme conflict. Please attempt to disable all plugins, and use one of the default (Twenty*) themes. If the problem goes away, enable them one by one to identify the source of your troubles.

    If you can install plugins, install and activate “Health Check”: https://wordpress.org/plugins/health-check/
    It will add some additional feature under create a new menu position Tools > Site Health.
    On its troubleshooting tab, you can Enable Troubleshooting Mode. This will disable all plugins, switch to a standard WordPress theme (if available), allow you to turn your plugins on and off and switch between themes, without affecting normal visitors to your site. This allows you to test for various compatibility issues.
    There’s a more detailed description about how to use the Health Check plugin and its Troubleshooting Mode at https://make.wordpress.org/support/handbook/appendix/troubleshooting-using-the-health-check/

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.