Support » Everything else WordPress » Comment Feed is not longer valid after 2.7 Update

  • After updating to 2.7 on different blogs, my comments feed is no longer valid. Feed Validator gives the following error:

    XML parsing error: <unknown>:18:51: not well-formed (invalid token)

    I took my investigation to another level and tried to add the feed to a feedburner account. Feedburner gives a more specific error:

    The URL you entered does not appear to be a valid feed. We encountered the following problem: Error on line 18: The reference to entity “cpage” must end with the ‘;’ delimiter.

    <b>Because the error refers to the link to an actual comment, the WILL validate as long as there are NO comments.</b>
    BUT… As soon as a comment is added to the blog, the error shows up.

    This is happening on two different domains, which are running two different themes.

    Is anyone else noticing this issue after updating? Any chance it is a bug in the new coding?

Viewing 7 replies - 1 through 7 (of 7 total)
  • Hello rreiter 🙂 I am a newbie with wordpress and the same thing is happening to me. Perhaps if now there are two persons with the same issue someone will sympathize with us give a little help?, at lest pointing us where to get info on how to solve this issue. Thanks in advance to the caring soul, and I apologize for English is not my mother language.
    Happy New Year to all the community.

    i am getting the same thing. on my site
    http://www.72off.net

    lets hope this gets solved soon.

    Seems to be a bug.

    See the patch http://trac.wordpress.org/ticket/8405 – for me it’s working now.

    The direct solution is here…
    Replace

    function comment_link() {
    echo get_comment_link();
    }

    by

    function comment_link() {
    echo htmlentities(get_comment_link());
    }

    in wp-includes/feed.php (around line 254).

    As described in the bug track the following would be better:

    function comment_lin() {
    echo clean_url(get_comment_link());
    }

    Sorry – made a mistake in the first line:

    function comment_link() {
    echo clean_url(get_comment_link());
    }

    Both solutions offered in the postings seemed to fix the problem. Comments feed is working again! Your help is MUCH appreciated! Thanks!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Comment Feed is not longer valid after 2.7 Update’ is closed to new replies.