WordPress.org

Support

Support » How-To and Troubleshooting » comment editing in 2.05

comment editing in 2.05

  • I recently upgraded to WP 2.05 and I’m running into a comment editing issue.

    Scenario:
    A comment is posted on my site with a grammatical error. I go to Manage> Comments> Edit Comment.

    The comment management screen comes up, I make edits, and press the “Edit Comment” button and receive the following error:

    “Fatal error: Call to undefined function: http_build_query() in /home/virtual/site367/fst/var/www/html/blog/wp-includes/functions.php on line 2463”

    Any solutions, thoughts, etc. would be greatly appreciated. Thanks

Viewing 2 replies - 1 through 2 (of 2 total)
  • Moderator Samuel Wood (Otto)

    @otto42

    WordPress.org Tech Dude

    Check to make sure that the functions-compat.php file exists and is complete and correct.

    This file contains backward compatible definitions for functions that are new to PHP. http_build_query() is something added in PHP 5, apparantly, so there’s a definition of it in here for older versions.

    I really recommend using PHP 5 with WordPress. It’ll be faster and better than older PHP versions.

    The functions-compat.php file on my server was not the same size (100 lines vs 114) as a newly downloaded version. I uploaded the new version and comment editing is now operational. Thanks Otto42 🙂

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘comment editing in 2.05’ is closed to new replies.