Support » Theme: Twenty Twelve » Comment Count not Visible on Posts Homepage. to do with Permalink change?

  • Resolved lolaaa

    (@lolaaa)


    Hello,

    I am having an Issue with my Comment Count not showing on my Posts Home-page.
    I did however notice, that when I change my Permalink setting, in my settings on my Blog, from Default, to Post Name, the comment count does not show up.
    But when I change back to Default it shows.

    Because how Ive set up my homepage, is to Link my Posts Title on Homepage to a PAGE. Not sure if this also could be the Issue as to why its not working..
    I also went to my Page php, and copied and pasted this line of Code: <?php comments_template( ”, true ); ?>

    into my Content Php, and also pasted it in my Index Php to see if it worked but still shows no Comment Count.
    all abit annoying for me as I cant figure out what I should do… 🙁
    I have Looked for hours in the Conversation Boards on my Problem but nothing on this Subject.

    Im using the Twenty Twelve Theme Version 3.5.1

    and uses My own Menu not the Primary menu to display My Latest post’s on My Home-page.

    anyone have any Clue as to how to Resolve this agh Help please.

    Thank you in Advance!!!

Viewing 15 replies - 1 through 15 (of 24 total)
  • The comment count has nothing to do with permalink setting. Permalink is just RewriteRule, it has nothing to do with what’s goin on in the template.

    If you are using child theme, revert to default Twentytwelve to see the different.

    Im not using a Child Theme using Default, is there a Line of Code that I can just put in my Content Php, or Index Php? to get the Comment Count to show? or other Php Files, my Page Comments show up on my Pages but when someone Comments on the Page its self, it does not show up on the Posts Homepage which is what I want it to do.

    Thank you for Response back 🙂

    comments_popup_link( ) is responsible for the comment numbers, but it is in the template, it’s not something you need to add in.

    It maybe that the page that assigned as home is using a custom template that doesn’t have comments_popup_link( ) in its content loop.

    I would suggest backing up your (edited) Twentytwelve theme, then upload the fresh Twentytwelve, and see what happens with the same permalink setting and the same front home setting.

    ok will try this out, will get back and let you know how it goes. THANK YOU!

    paulwpxp I have done what you have Suggested:

    comments_popup_link( ) is responsible for the comment numbers, but it is in the template, it’s not something you need to add in.

    It maybe that the page that assigned as home is using a custom template that doesn’t have comments_popup_link( ) in its content loop.

    I would suggest backing up your (edited) Twentytwelve theme, then upload the fresh Twentytwelve, and see what happens with the same permalink setting and the same front home setting.

    I went through everyone of My Php Templates and put the Code above as you mentioned inside the Loop: <?php comments_popup_link( ‘<span class=”leave-reply”>’ . __( ‘Leave a comment’, ‘twentytwelve’ ) . ‘</span>’, __( ‘1 Comment’, ‘twentytwelve’ ), __( ‘% Comments’, ‘twentytwelve’ ) ); ?>

    thats what My Twenty Twelve Comments code is but still no Comment Count 🙁
    so I then Installed a Fresh New Twenty Twelve Theme and did what you Suggested everything the same, did no Edits! of this New Install and no Comment Count.

    So thought let me change the Permalink setting again from (Post name) to (Default) and what do you know the Comment Count does show if I comment on a Page, it does show on my Posts Homepage.
    But when I change it to (Post name) Nothing.

    Since I am not using Twenty Twelve (Primary Menu)
    I created My own Menu called (sub menu)
    So has now created a New Sub menu Php Folder or should it be a Template Folder?? and what should I paste in there? is this the Right thing I should do? I did paste the comments_popup_link( ) in there to test it out but nothing still the same no Counts Baffling.

    I hope all My Infomation above has helped.
    Thanks in Advance for any Help given

    So with the fresh install of 2012,

    • the comment count doesn’t show when permalink set to post name
    • it shows when permalink set to default

    And this happens on home page, which is a page listing all posts, that you assign to be blog home (Posts page) in Settings > Reading, am I correct ?

    Yeah that’s all Correct. to make things easier here is a Lik to my site for you to have a better understanding really hope one can sort this out lol.

    dailydoseoflovely.com

    Thanks again 🙂

    sorry my front page is set to display My Latest Posts!

    if you would like you can post a Comment on my posts homepage you scroll down, there you will see a Leave a Comment next to Post.
    it will direct you to my Page.
    then come back to my Homepage and you will see it doesn’t show.

    The comment counts display on the page you link to. I could see there is 1 comment on “Beauty Essential: My Hair Care Ammo”, and no comment on others so it displays “Leave a comment.”

    oh that 1 comment is there, because the Permalink setting was on Default.
    then I changed to Post name, but that 1 comment still shows I should of deleted it sorry. I edited the Leave a Comment txt in my Functions or Content Php I forgot now but its’s one of them two.
    Now what I will do if you are still there, I will change the Permalink right now for you, to Defaults and see what happens. Maybe you can tell me what I am doing So wrong this is really Weird to me, one would think this would of been soooooo Easy how wrong am I..:)

    paulwpxp Permalink change done for you

    see what I mean… I dont want the comment count to come from that Page it takes the Counts from, all I would like it to do is to get the Comment count from the Actuall page the Post’s Title Links you too if that makes any sense…

    Im so so Grateful for all of your Help paulwpxp

    One more thing,
    Do you mind letting me know when you or if you can view my Permalink change I did for you, so’s I can set it back to Post name thanks.

    With permalink set to post name (earlier) and set to default (now), the comment count does show in both cases.

    I’m under the impression that what you’re meant to say is that the comment doesn’t appear in the page and the comment number doesn’t count up.

    If that’s so, check Settings > Discussion see what you have under “Before a comment appears”.

Viewing 15 replies - 1 through 15 (of 24 total)
  • The topic ‘Comment Count not Visible on Posts Homepage. to do with Permalink change?’ is closed to new replies.