Support » Fixing WordPress » Comment boxes not showing on posts

  • Resolved Shaunus4

    (@shaunus4)


    Hello lovely WordPresss heroes, I hope you can help me with my problem.

    I am setting up a blog page for the first time on my WordPress.org site, which has long existed with a static homepage. I have successfully created a posts page (http://www.teqs.net/seed-beneath-snow-film/) through Settings>Reading, and my posts are now appearing. So far, so good.

    As you will see, I have posted three sample posts and commenting is successfully enabled for all three, as will be apparent when you look at the page. I have even been able to post a test comment on one of them (by navigating to that post through the dashboard and posting directly from the “edit post” section).

    However, my problem is that no comment box appears on any of the three posts, so nobody else can post comments. I have tested this in Firefox 55.0.3 and Chrome 61.0.3163.79, both using Windows 10 Pro.

    Any advice very welcome as to how I might cause the comment boxes to become visible/functional on the posts. The aim of the page is to collect input on the film we are making about my late friend, so it’s not much use without people being able to comment! 🙂

    Thanks,
    Shaun

    The page I need help with: [log in to see the link]

Viewing 10 replies - 1 through 10 (of 10 total)
  • Hi Shaun,

    It might be that comments need to be approved before being posted so they don’t appear, you need to disable this option.

    Go to settings and then the discussions option in your WordPress dashboard.

    You’ll see the default article settings under which you need to enable the “Allow people to post comments on new articles” option.

    Let me know if this works.

    Best Regards,
    Sudais A.

    • This reply was modified 2 years, 2 months ago by Sudais Asif.

    Thanks for the reply Sudais.

    That’s not the problem though. The setting is already ticked, and here is a screenshot of the Settings>Discussion page, to save your having to enquire about other settings:
    http://i148.photobucket.com/albums/s17/Shaunus4/Used%20pictures/FPC%20discussion%20settings_zpskc8b32un.jpg

    I can also confirm that comments are enabled on all three posts, as you can see for yourself on the page, since it lists the number of comments posted.

    What else might be to blame?

    Thanks,
    Shaun

    Moderator stephencottontail

    (@stephencottontail)

    Have you spoken to your theme’s author? It looks like you’re using a completely custom theme.

    Ah, no I haven’t. The site was built back in 2011 for my late friend, looks like, and I’ve not been in touch with the author.

    Do you believe there may be a unique issue here that only they can resolve? Or is there anything else that I can try before resorting to seeking the author out?

    Thanks stephencottontail.

    Moderator stephencottontail

    (@stephencottontail)

    When someone is using a custom (or commercial) theme, we can’t see the actual PHP files that make up the theme, so it’s difficult for us to help in certain situations. We can make guesses, but it’s usually easier and faster if the theme’s author helps out instead.

    With that being said, here’s a guess. Does your theme call comments_template()?

    The theme was tested on WordPress 2.2, it could also be possible that it has gotten outdated over the years since now WordPress 4.8+ is being used and because of that you’re facing this error.

    Thanks both, and stephencottontail in particular, since it sounds as though you are helpfully going above and beyond.

    While not fully familiar with the terminology you’re using, I went into Appearance>Editor and searched on every template of the theme for “comments_template”. I found nothing.

    By comparison, on my own site I found in in index.php That probably answers your kind question, and possibly not to my benefit..?

    In case helpful (to you, in being helpful to me!) I have posted the index.php file of TEQs.net’s theme into a text file here:
    http://www.teqs.net/TeqsIndexPHP.txt

    If I need to chase up the theme author, I guess that’s what I’ll do, but any other tips v welcome.

    Thanks again,
    Shaun

    Moderator stephencottontail

    (@stephencottontail)

    It might work to add the call to comments_template() on line 29, prior to <?php endwhile; ?>, but I’d highly suggest tracking down the theme’s author, if for no other reason that it might be faster.

    Ok, I tried that (to the best of my understanding) by adding the following – copied from my own site’s template – to the index.php file where you said:

    <?php comments_template(); // Get wp-comments.php template ?>

    There’s probably more to it, since I have no idea what I’m doing, as is doubtless obvious!

    Anyway, no joy, so I’ve put it back to how it was and will try to chase up the theme author, as you suggest.

    Many thanks for the helpful advice – I stood no chance at working this out on my own – and I’ll mark this thread as resolved now, since I need to pursue the solution elsewhere.

    Best,
    Shaun

    Did you tried adding that line in the single.php file?
    before the closing tags of the site content?

    bet luck if you return here!!

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Comment boxes not showing on posts’ is closed to new replies.