WordPress.org

Forums

Comment box not showing up? (28 posts)

  1. shiva777
    Member
    Posted 10 years ago #


  2. shiva777
    Member
    Posted 10 years ago #

    Hello all. I am going nuts here trying to figure this out. For some reason, the little box that shows up that allows people to post comments does not show up on my site (the one with name,email, comments etc). There is no way to post comments.

    I am using 1.5 with the Trident theme. "Comments allowed" is checked. Permalinks are on and seem to be working otherwise. The comment link goes to http://www.mysite.com/the_category/#comments so that looks OK. The post shows up on that page fine, but no way to make comments. Any ideas?

    Here is relevant code from the templates index.php file:

    <div class="feedback">
    <?php wp_link_pages(); ?>
    <?php comments_popup_link(__('Comments (0)'), __('Comments (1)'), __('Comments (%)')); ?>
    </div>

    <!--
    <?php trackback_rdf(); ?>
    -->

    </div>

    <?php comments_template( is_single() ); // Get wp-comments.php template ?>

    -----------------------------

    Thank you so much for any help!!

    -shiva

  3. fernashes
    Member
    Posted 10 years ago #

    Have you got a popup killer on your browser?

  4. shiva777
    Member
    Posted 10 years ago #

    Good idea but no its not a popup blocker. I just got another clue...when I turned off permalinks it now works. But I do want the permalinks on so any other ideas would be most welcome.

    -shiva

  5. krisandapril
    Member
    Posted 10 years ago #

    I have exactly the same problem. No one can post on my site and I just can't figure it out. My site is at: krisandapril.us

  6. lawtai
    Member
    Posted 10 years ago #

    try copying the comments.php and the popup-comments.php file from the classic theme over to your trident theme.

  7. moshu
    Member
    Posted 10 years ago #

    This:
    <?php comments_template( is_single() ); // Get wp-comments.php template ?>
    should be:
    <?php comments_template(); // Get wp-comments.php template ?>

  8. woohooblog
    Member
    Posted 9 years ago #

    I am also having this issue. I am getting nothing that allows anyone to post comments. However, when I turn off permalinks, it works just fine. Does anyone have any idea how I can use permalinks and also actually have visitors post comments? Thank you in advance for any help you can give.

  9. pericat
    Member
    Posted 9 years ago #

    Offhand, I'd say you've fixed this. I just posted a comment via the handy link at the bottom of the post on your blog.

  10. woohooblog
    Member
    Posted 9 years ago #

    Yes, I turned off the permalinks feature, which is something I really don't want to do. When permalinks is on, the comment box area doesn't show up at all.

    Do you have any suggestions on how to get the comments area to show up while also having permalinks turned on? Thanks in advance!

  11. pericat
    Member
    Posted 9 years ago #

    Ah! Sorry. If you switch to the default theme, do you still have the same problem?

  12. woohooblog
    Member
    Posted 9 years ago #

    Yes I still have the same issue with both default and the classic theme. This is my third fresh install today and I just can't figure this out.

  13. pericat
    Member
    Posted 9 years ago #

    Could you turn permalinks back on for a bit?

  14. woohooblog
    Member
    Posted 9 years ago #

    They are turned back on now.....and no comment area. :(

  15. woohooblog
    Member
    Posted 9 years ago #

    Okay, I'm turning off the permalinks again so I can do some more work on my site.

  16. pericat
    Member
    Posted 9 years ago #

    Sorry to miss you; thought you'd taken off for the night.

  17. pericat
    Member
    Posted 9 years ago #

    I can create a problem similar to the one you describe if I leave out %postname%/ from the end of the permalink structure.

  18. woohooblog
    Member
    Posted 9 years ago #

    I always use the permalink structure offered (I just cut and paste it):

    /%year%/%monthnum%/%day%/%postname%/

    And then for category base I use:

    /cat

    So, I have been including the /%postname%/ at the end of the permalink. Thanks for your help, by the way. :)

  19. tdellaringa
    Member
    Posted 9 years ago #

    This seems to be a popular problem, I too am having this problem and using permalinks :( I am also using postname in my structure:

    /notebook/%year%/%monthnum%/%postname%

    is this a known bug? I *really* want my permalinks just like this and don't want to change it... Seems like an odd bug. I too am using a custom theme, although I have not really played around with much other than look and feel.

    Anyone have any solutions?

  20. tdellaringa
    Member
    Posted 9 years ago #

    Nobody has a solution eh? Does the latest upgrade fix this?

  21. Uppa
    Member
    Posted 9 years ago #

    Well I think I had the same problem of comments not showing and, by browsing this forum, I understood that it was something to do with permalinks. In fact I added a category to the only one I had, posted an article and discovered to my horror that categories were not working either. My school's website is hosted on IIS 4.0.
    http://www.istitutopessina.it/blog (in Italian eh! I AM Italian)
    I tried adding . htacces file which did not exist and a php.ini (as suggested somewhere where talking about permalinks) but nope...
    The solution was changing the structure of my permalinks (from Options > Permalinks) so that it looks like this /index.php/archive/%postname%/
    Now everything seems to work.
    Keep fingers crossed and see if this may be of any use.
    Thanks everyone for keeping this forum up, it's vital!

  22. tdellaringa
    Member
    Posted 9 years ago #

    Thanks for the suggestion Uppa - unfortunately no matter how I change my permalink structure, nothing seems to work. I don't get comments. Even if I turn them OFF I don't get them.

    Maybe it's time to back up my data and re-install...

  23. vkaryl
    Member
    Posted 9 years ago #

    That's probably a good place to start. Also be really sure you have the trailing / after %postname%. And double check with your host to make sure there's not something odd about you using .htaccess (you do have the file in the ROOT of your wp install, right?), and that they haven't got something strange in THEIR php.ini.... and have you made sure you have the comments.php file in your theme folder? (That isn't always a necessity but the ONLY time I've had this problem, copying the file from default into my custom theme fixed it *shrug*).

  24. moshu
    Member
    Posted 9 years ago #

    Dumb question, but...
    Do you have the proper call in your single.php for the comments template?

  25. MikeMoore
    Member
    Posted 9 years ago #

    Hello everyone,

    New user here. I've been reading about comments and tried to apply what I've read here to my situation, but to no avail. I'm trying to get a comments box to show up on a "page". I've checked the comments box but that is not the solution. I'm using wordpress 1.5.2
    Any suggestions?
    Mike

  26. vkaryl
    Member
    Posted 9 years ago #

    Hmm. Don't normally use pages myself, seems I recall some posts saying you don't get a comments section on pages. Did you search?

  27. moshu
    Member
    Posted 9 years ago #

    MM, in the theme you are using there is no call for the comments template in the Page template.
    (and don't even try with that theme to include the comments into a Page - you'll be back asking for help and nobody will jump in...)

  28. MikeMoore
    Member
    Posted 9 years ago #

    Thanks for the advice, I'll leave well enough alone...

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.