Support » Fixing WordPress » Comment box not showing beneath posts

  • Sharen McArthur


    I use Jetpack Comments along with WordPress Comments. I have WordPress 2016 theme. I followed the directions in your “Comments in WordPress” document in support in to set up comments and make the comment box show beneath posts – to no avail.

    No comment box shows under any of my posts. The comment box does show on my Comments Guidelines page, but only on my desktop website, not my mobile website.

    In the Jetpack settings, I have these things enabled:
    * Let visitors use a, Twitter, Facebook, or Google account to comment.
    * Enable pop-up business cards over commenters’ Gravatars.
    * Enable comment likes.
    * Let visitors subscribe to new posts and comments via email
    * Enable the “subscribe to site” option on your comment form
    * Enable the “subscribe to comments” option on your comment form

    In the WordPress settings- discussion, I don’t have the following checked because I saw a note that the comment form wouldn’t show if I checked it: Users must be registered and logged in to comment. So again, it’s not checked, but I still don’t have comment boxes after my posts.

    To try to remedy the problem, I have turned off the settings in Jetpack that I mentioned above, and I still don’t get comment boxes beneath my posts, but I still get the comment box on my Comments Guideline page on my desktop website.

    1. How do I get comment boxes to show under my posts?
    2. And, how do I get the comment boxes to show on my mobile website? I use WPtouch Pro for my mobile website. On the Comments Guidelines page on my mobile website, the comment box doesn’t appear (even though it appears on that page on my desktop website). And no comment boxes appear under posts on my mobile website.

    Thank you for your help.

    The page I need help with: [log in to see the link]

Viewing 11 replies - 1 through 11 (of 11 total)
  • The WordPress Discussion settings control what happens for new posts. (although there are settings for automatic closure of comments after a time period)
    Once a post is published, it has its own setting for whether comments are open or closed. Comments that are created should always be shown, regardless of whether the current setting is open or closed.
    The theme only shows the comment form if the options are set for it.

    Plugins can alter this, but it is unlikely that JetPack is doing it wrong.
    The plugin for a mobile site could be doing anything. Did you try it without the plugin? (with a good theme, a plugin for mobile is unnecessary)

    Thread Starter Sharen McArthur


    Thank you for your response. I forgot to mention that I had turned on comments for each post, by selecting allow for each post. I still don’t have a comment box.

    I am not sure what you mean by this statement: “The theme only shows the comment form if the options are set for it.” I followed all of the WordPress Comment directions for the settings, including allowing comments for all posts. And I don’t require users to be logged in and registered to post.

    In regards to my mobile website and Jetpack, I disabled the Jetpack comment settings. But I still have no comment boxes at all on my mobile website.

    So is there some setting I am missing? I have allowed comments for all posts, but I don’t have comment boxes at the bottom of the posts.

    Thread Starter Sharen McArthur


    After I posted my reply, I found a website that had a similar problem in 2018. this is a link to it:

    Near the bottom of the post, someone suggested looking at the permalink. The person seeking support stated, “When I used default template in permalink then comment box appeared.”

    Not sure if this is my problem or not. My permalink is set to: Post name

    I just tested the Twenty Sixteen theme and it is showing the comments in the correct circumstances. It also prints “Comments are closed.” if that is the case.
    So I would suspect one of your plugins, especially the one for mobile.

    Thread Starter Sharen McArthur


    Thank you for your response.

    So you suspect my mobile plugin is stopping comments from appearing on my desktop website and my mobile website?

    Could you please tell me the names of other plugins that have been found to block comment boxes? I am sure there may be a lot, but are there some that usually do that?

    Thanks for your help.

    Thread Starter Sharen McArthur


    Since my last reply, I have done some more investigation about the comments box problem.

    I had only allowed comment boxes on my posts (where the comment boxes still don’t show). Today I decided to add comment boxes to my pages and…the comment boxes immediately showed up!

    So…I looked at my menu and it reminded me of something: On my menu I have “regular” pages and the comment boxes show up on these “regular” pages.

    I also have categories on my menu. My posts are added to my menu through category. In other words, all of my posts in the categories on my menu don’t show the comment boxes. My posts are in Your True Stories category on the menu; in True Stories on the Web category on the menu; and in Stories Blog category on the menu. Again, none of the stories in these categories on the menu show the comments box.

    Could the fact that my posts are all in categories on my menu be the reason why the comment boxes aren’t showing on the posts? If so, how can I fix this problem?

    Thread Starter Sharen McArthur


    Could someone please tell me if the posts being in categories on the menu interferes with WordPress Comments. Thank you.

    There is no relationship between the menu and the comments, unless you have a plugin that does something like that.

    Thread Starter Sharen McArthur


    Thank you for your reply. I don’t have a plugin that controls the menu. I don’t have a plugin that has a relationship between the menu and comments. I was trying to discover why I don’t have comment boxes beneath my posts. It was a difference that I noticed from the other pages.

    Do I need to disable WordPress comments and then re-enable them, if that is possible? I don’t know what to do to get comment boxes to show beneath my posts. What do I do to get comment boxes to show beneath my posts?

    Thread Starter Sharen McArthur


    Is there anything that can be done to fix this problem?

    Can you look again at the Settings > Discussion page and see if you have chosen the option to disable comments after a certain time period? Read all the options there carefully.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Comment box not showing beneath posts’ is closed to new replies.