Support » How-To and Troubleshooting » [Resolved] Comment box not enabled

[Resolved] Comment box not enabled

  • I just launched a new blog, everything nice, made a test post and invited my friends to come by and comment. Now the comment box won’t enable. I have been making lots of customization, so it’s hard to track down what is causing this, exactly…but it doesn’t seem to be a setting I can change, it seems like a code glitch. Maybe plug-in problems, but I turned a few suspects off and still no comment box.
    I saw it exactly one time when I made a test comment and it worked just fine…did I disable comments when I deleted that, or is it something else?…help!

Viewing 15 replies - 1 through 15 (of 51 total)
  • This is the kind of question that might generate more response if you shared a link so that helpers could see the issue.

    Okay…my blog is here

    I have a very similar problem. In my “post” page, I have my posts listed alright and also the number of comments is shown OK. But I don’t see the comment box, whatever I do.

    I use WP 2.2.1, the site is


    I apologize for the Slovene language of the text, but since php is universal I hope someone might help. The page where I keep the posts is called “Novice”.

    Thank you a lot!

    Yep…that’s the same thing that happened to me. Did you make any mods since you last had it working? Installed or turned on a plug in? Or changed anything related to comments, the last time my comments worked I deleted a test comment. Did you do something like that too?



    Forum Janitor

    If you temporarily switch back to the default theme, do you get the ability to comment back?

    Good suggestion, that would certainly narrow it down, but no, it is reacting the same. The link takes me to a subpage that says “respond” but no comment box appears after switching to default. Just as well, I didn’t want it to be my theme’s fault.



    Forum Janitor

    That’s odd. I would have felt sure that it would be a theme related issue. Not putting the box on the template or something.

    Oh well.

    Is the “allow comments” box ticked at both post-level and blog level?

    Unless there is some other place to do it…the thing is, I had it working, made a comment to test, deleted it, and then heard from my friend that it didn’t work. I changed many things, but yes, every possible permission has been given to the system to enable comments. I’ve disabled a plug-in and am considering deleting it to see if that fixes it.
    Is there a possibility this is a WP problem related to the recent upgrade? I’m using 2.21

    I also have the allow comments checked. I use a theme that comes in two colors. Even if i change to the other-color-theme (which I haven’t touched), the comments box does not appear. the most annoying thing is that everything worked fine with the same theme after I installed WP. The problem occurred when I started to modify things and activated plug-ins.. And yes — I also have deleted the test comment..

    Just moved all plugins to the root directory…I’m down to orginal template and my one post…I deconstruct too much more and I may as well just reinstall.
    I think it was deleting the test comment. That’s why no one can help us. It is a bug. Unless an experienced moderator can save us…
    I am sure we have the same glitch, my friend. Either deleting the test comment we also deleted the comment section, or it was a plug-in…but mine have been removed.
    Good luck. I don’t think the theme is the problem, but it may come down to a fresh install.



    Forum Janitor

    I’m not sure how deleting a test comment would produce the behaviour you are describing, though. Unless there is an odd glitch when there’s nothing in the database.

    You could practically reinstall anyway by upgrading to 2.2.2…. (It is a recommended ugprade)

    Do you have direct access to your mysql database?

    I’m sure there must be a way, although pasting original code all around the place didn’t help.

    @mrmist >> I do. I have installed the WP via Fantastico. I don’t know if this matters here, but it was an issue elsewhere — I had to change config.php (as suggested by one of the moderators) in order to see all of the characters we have in our language.

    This is what the code in my template is:

    <?php if ( have_posts() ) : while ( have_posts() ) : the_post(); ?>

    <div class=”post” id=”post-<?php the_ID(); ?>”>
    <h1>” rel=”bookmark”><?php the_title(); ?></h1>
    <div class=”meta”><?php the_date(); ?> @ <?php the_time() ?> <?php edit_post_link(__(‘Edit This’)); ?></div>

    <div class=”storycontent”>
    <?php the_content(__(‘(more…)’)); ?>

    <div class=”feedback”>
    <?php wp_link_pages(); ?>
    <?php comments_popup_link(__(‘Comments (0)’), __(‘Comments (1)’), __(‘Comments (%)’)); ?>



    <?php comments_template(); // Get wp-comments.php template ?>


    I have resolved the issue. It was a two-fold problem. I used permalinks and when I clicked the “No Comments” link it just threw me to the same site, not to the single post page. After setting permalinks back to default, the single post page showed up — with no comments or comments box. I found out that my theme was missing single.php. And since I have changed my index.php into a static page (no comments) this was a problem. After creating a single.php with comments stuff everything is OK.

    Thanks for brainstorming..

    (..although I miss permalinks!)

Viewing 15 replies - 1 through 15 (of 51 total)
  • The topic ‘[Resolved] Comment box not enabled’ is closed to new replies.