WordPress.org

Forums

[resolved] Comment box not enabled (52 posts)

  1. AmanaMission
    Member
    Posted 7 years ago #

    I just launched a new blog, everything nice, made a test post and invited my friends to come by and comment. Now the comment box won't enable. I have been making lots of customization, so it's hard to track down what is causing this, exactly...but it doesn't seem to be a setting I can change, it seems like a code glitch. Maybe plug-in problems, but I turned a few suspects off and still no comment box.
    I saw it exactly one time when I made a test comment and it worked just fine...did I disable comments when I deleted that, or is it something else?...help!

  2. Chris_K
    Member
    Posted 7 years ago #

    This is the kind of question that might generate more response if you shared a link so that helpers could see the issue.

  3. AmanaMission
    Member
    Posted 7 years ago #

    Okay...my blog is here

  4. zhaval
    Member
    Posted 7 years ago #

    I have a very similar problem. In my "post" page, I have my posts listed alright and also the number of comments is shown OK. But I don't see the comment box, whatever I do.

    I use WP 2.2.1, the site is

    http://pedkl.com/novice

    I apologize for the Slovene language of the text, but since php is universal I hope someone might help. The page where I keep the posts is called "Novice".

    Thank you a lot!

  5. AmanaMission
    Member
    Posted 7 years ago #

    Yep...that's the same thing that happened to me. Did you make any mods since you last had it working? Installed or turned on a plug in? Or changed anything related to comments, the last time my comments worked I deleted a test comment. Did you do something like that too?

  6. mrmist
    Forum Janitor
    Posted 7 years ago #

    If you temporarily switch back to the default theme, do you get the ability to comment back?

  7. AmanaMission
    Member
    Posted 7 years ago #

    Good suggestion, that would certainly narrow it down, but no, it is reacting the same. The link takes me to a subpage that says "respond" but no comment box appears after switching to default. Just as well, I didn't want it to be my theme's fault.

  8. mrmist
    Forum Janitor
    Posted 7 years ago #

    That's odd. I would have felt sure that it would be a theme related issue. Not putting the box on the template or something.

    Oh well.

    Is the "allow comments" box ticked at both post-level and blog level?

  9. AmanaMission
    Member
    Posted 7 years ago #

    Unless there is some other place to do it...the thing is, I had it working, made a comment to test, deleted it, and then heard from my friend that it didn't work. I changed many things, but yes, every possible permission has been given to the system to enable comments. I've disabled a plug-in and am considering deleting it to see if that fixes it.
    Is there a possibility this is a WP problem related to the recent upgrade? I'm using 2.21

  10. zhaval
    Member
    Posted 7 years ago #

    I also have the allow comments checked. I use a theme that comes in two colors. Even if i change to the other-color-theme (which I haven't touched), the comments box does not appear. the most annoying thing is that everything worked fine with the same theme after I installed WP. The problem occurred when I started to modify things and activated plug-ins.. And yes -- I also have deleted the test comment..

  11. AmanaMission
    Member
    Posted 7 years ago #

    Just moved all plugins to the root directory...I'm down to orginal template and my one post...I deconstruct too much more and I may as well just reinstall.
    I think it was deleting the test comment. That's why no one can help us. It is a bug. Unless an experienced moderator can save us...
    I am sure we have the same glitch, my friend. Either deleting the test comment we also deleted the comment section, or it was a plug-in...but mine have been removed.
    Good luck. I don't think the theme is the problem, but it may come down to a fresh install.

  12. mrmist
    Forum Janitor
    Posted 7 years ago #

    I'm not sure how deleting a test comment would produce the behaviour you are describing, though. Unless there is an odd glitch when there's nothing in the database.

    You could practically reinstall anyway by upgrading to 2.2.2.... (It is a recommended ugprade)

    Do you have direct access to your mysql database?

  13. zhaval
    Member
    Posted 7 years ago #

    I'm sure there must be a way, although pasting original code all around the place didn't help.

  14. zhaval
    Member
    Posted 7 years ago #

    @mrmist >> I do. I have installed the WP via Fantastico. I don't know if this matters here, but it was an issue elsewhere -- I had to change config.php (as suggested by one of the moderators) in order to see all of the characters we have in our language.

  15. zhaval
    Member
    Posted 7 years ago #

    This is what the code in my template is:

    <?php if ( have_posts() ) : while ( have_posts() ) : the_post(); ?>

    <div class="post" id="post-<?php the_ID(); ?>">
    <h1>" rel="bookmark"><?php the_title(); ?></h1>
    <div class="meta"><?php the_date(); ?> @ <?php the_time() ?> <?php edit_post_link(__('Edit This')); ?></div>

    <div class="storycontent">
    <?php the_content(__('(more...)')); ?>
    </div>

    <div class="feedback">
    <?php wp_link_pages(); ?>
    <?php comments_popup_link(__('Comments (0)'), __('Comments (1)'), __('Comments (%)')); ?>

    </div>

    <div>

    <?php comments_template(); // Get wp-comments.php template ?>
    </div>

    </div>

  16. zhaval
    Member
    Posted 7 years ago #

    I have resolved the issue. It was a two-fold problem. I used permalinks and when I clicked the "No Comments" link it just threw me to the same site, not to the single post page. After setting permalinks back to default, the single post page showed up -- with no comments or comments box. I found out that my theme was missing single.php. And since I have changed my index.php into a static page (no comments) this was a problem. After creating a single.php with comments stuff everything is OK.

    Thanks for brainstorming..

    (..although I miss permalinks!)

  17. AmanaMission
    Member
    Posted 7 years ago #

    Okay, this is a WORDPRESS bug and it is uncool. I reinstalled the update, everything was sweet until I set permalinks and then poof! Comments gone!
    A day wasted! And no help from any moderator!
    I like WP but this update stuff is overdone, I lost a lot of little tweaks and I have to shut my blog down without permalinks.
    I want to report this as a definite development bug:
    Permalinks causing comment error!
    But thank you WP for the nice CMS and please patch this!

  18. AmanaMission
    Member
    Posted 7 years ago #

    This is soooo frustrating! So I have to choose between comments and permalinks? What the h... Is there any other way to generate permalinks, they are incompatible with comments, aren't others having this issue?
    Why aren't the mods stepping forward with some diagnosis? Volunteers, yes, but this should be happening to others!

  19. Chris_K
    Member
    Posted 7 years ago #

    While the howls of frustration do indeed elicit sympathy, please do not confuse forum moderators with WordPress designers or coders.

  20. AmanaMission
    Member
    Posted 7 years ago #

    Okay, I do understand the distinction. Been about twelve hours, though, and I think if this is happening to more than one person, the entire community should at least be able to advise as to the nature of the bug. That is neither here nor there. Is there anything I can do about this?

  21. AmanaMission
    Member
    Posted 7 years ago #

    After scouring the source code for a while longer, I see that comments are enabled and "No comments" is being displayed beneath each post.

    When the permalinks are set to "default" the comment option works just fine. The url being displayed (for the first post) is
    "http://www.{my-url}.com/?p=1#respond"

    when set to custom permalinks it displays
    "http://www.{my-url}.com/postname/#respond"

    when I manually enter the "?p=1" before the "#respond"
    (showing "http://www.{my-url}.com/postname/?p=1#respond" )
    the comments work! (p=1 for post 1, p=2 for post 2 and so on)

    Therefore the active link directing to the comments page from the post page seems to be incorrect.

    I was not able to locate the source code directing that URL. Which file would it be in?

    Ideally the permalinks would be set up to post name rather than the number and the ?p=1;2;3 etc would be working as well.

    Can anyone help tell me where to find the the code directing to the comments page and how change it so that the url is correct?

  22. mrmist
    Forum Janitor
    Posted 7 years ago #

    If your comments aren't working when you have pretty permalinks, then it could be a .htaccess issue. If you have access to check, check that the .htaccess file is being updated by wordpress when you change to pretty permalinks.

  23. AmanaMission
    Member
    Posted 7 years ago #

    I am pretty sure that the files are being updated, because the urls for the links are changing.

    Which file, exactly, would be one affecting this?

  24. mrmist
    Forum Janitor
    Posted 7 years ago #

    The URLs as in the links that are displayed will change because the database changes, but it's the .htaccess file that will determine whether those links work or not.

    The file you would be looking for would be .htaccess in the directory that your blog main index is in.

  25. AmanaMission
    Member
    Posted 7 years ago #

    Well, that could have something to do with it...
    I tried to view the .htaccess file and the the message came back -
    Forbidden
    You don't have permission to access /consciousness/.htaccess on this server.

    I changed the perms for full access for the owner, public can read and group can read and write (public and group are set to default...)

    but the comments are still not working.

    What should the .htaccess be set to?

    Could there be another way to set the URL correct?

  26. zhaval
    Member
    Posted 7 years ago #

    @AmanaMission

    Check this link, perhaps you can find something helpful..

    http://wordpress.org/support/topic/100378?replies=13

  27. mrmist
    Forum Janitor
    Posted 7 years ago #

    Well, that could have something to do with it...
    I tried to view the .htaccess file and the the message came back -
    Forbidden
    You don't have permission to access /consciousness/.htaccess on this server.

    Yeah. You won't be able to view it directly through the browser, you'd have to look at it through shell access onto the server, or by downloading it in your ftp client.

    I changed the perms for full access for the owner, public can read and group can read and write (public and group are set to default...)

    but the comments are still not working.

    What should the .htaccess be set to?

    Depending on how your web hosting works, you *may* need to set it to world-writable, update your permalink style using wordpress, then set it back to user only writable.

    Could there be another way to set the URL correct?

    Not really.

  28. AmanaMission
    Member
    Posted 7 years ago #

    Resetting perms for .htaccess doesn't seem to do it either! Could this be related to the version of PHP (5.2)I'm running?

    zhaval, if you see this...did you give up on permalinks or did you get it to work somehow...if you fixed it, can you please show me exactly how you did it?

    I wonder what is similar about our server configuration to cause this. Zhaval, if you are still subscribed, I'd like to brainstorm a little more, as you probably know more about this than anyone.

    I could really use a talented troubleshooter to help me get around this! I promise my blog will be really great!

  29. AmanaMission
    Member
    Posted 7 years ago #

    Quote:
    zhaval
    Member

    "AmanaMission

    Check this link, perhaps you can find something helpful..

    http://wordpress.org/support/topic/100378?replies=13 "

    Hmm...doesn't seem to be addressing the same issue...

    I created a temporary work-around be adding the url to the comments page as part of every post...but that isn't really a great solution, because the post url still doesn't work - if you click on the title of a post, the url shows the post name correctly, but the page continues to display the blog homepage with all of the posts
    :(

  30. whooami
    Member
    Posted 7 years ago #

    what does your .htaccess that is located in the root directory of your site say..

    the front page of your site loads and sends a 200 pretty much no matter what url I put in:

    http://bookofmoron.com/index1.html -- for instance.

    Thats NOT normal.

    Additionally. IF you look at your source, you will see that you are using

    https://amanamission.sslpowered.com as one of your urls.

    Whats the deal with that?

    Some of your files are sending 500s (generic errors) and I suspect it's due to whatever redirection thing/subdomain setup you have going on.

    --------

    Ive followed this thread quietly, and became hesitant to add anything to it, once you lashed out at this being a bug. I suspect its NOT a bug at all, and due to what you have set up.

Topic Closed

This topic has been closed to new replies.

About this Topic