Support » Fixing WordPress » Comment area replace with login to comment

  • The problem is that when the page is loading the Leave a Reply and comment box is there….but after it loads, it’s replaced by Please login to comment (and I’m already logged in). Side note, I have allowed comments on all my blog posts and don’t require a user to login to comment.

    Here’s a sample page: https://sitinuriatistudio.com/how-to-paint-a-pomegranate-with-pastel/

    I viewed the page and it shows the Leave a Reply, BUT if I INSPECT the page, it doesn’t have it, just the Please login to comment. I also searched the page…and found some JS that may be the culprit…but I wouldn’t know how to delete it from the page, since it only shows up when I view the page.

    1) Here’s what shows up when I VIEW the page

                 <!--Comments Area-->                                
                                    <div class="comments-area text-left">
                                         
    
    			<!-- If comments are open, but there are no comments. -->
    
    	 
    
    <div id="respond" class="respondbg">
    
    	<div id="respond" class="comment-respond">
    		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" href="/how-to-make-a-smile-big-mini-gift-card/?preview_id=5712&preview_nonce=a7197d1f68&post_format=standard&_thumbnail_id=5287&preview=true#respond">Click here to cancel reply.</a></small></h3>			<form action="https://sitinuriatistudio.com/wp-comments-post.php" method="post" id="" class="comment-form" novalidate>
    				<p class="logged-in-as"><a href="https://sitinuriatistudio.com/wp-admin/profile.php">Logged in as sitinuriati</a>. <a href="https://sitinuriatistudio.com/wp-login.php?action=logout&redirect_to=https%3A%2F%2Fsitinuriatistudio.com%2Fhow-to-make-a-smile-big-mini-gift-card%2F&_wpnonce=46eb86d5c4">Log out?</a></p><div class="clear"></div><p class="form-allowed-tags"></p>
    <section class="comment-form-comment form-group"><div id="comment-textarea"><textarea id="comment" name="comment" placeholder="Message"  cols="45" rows="8"  class="textarea-comment form-control" aria-required="true"></textarea></div></section><p class="form-submit"><input name="submit" type="submit" id="" class="submit" value="" /> <input type='hidden' name='comment_post_ID' value='5712' id='comment_post_ID' />
    <input type='hidden' name='comment_parent' id='comment_parent' value='0' />
    </p><input type="hidden" id="_wp_unfiltered_html_comment_disabled" name="_wp_unfiltered_html_comment_disabled" value="c4dea14080" /><script>(function(){if(window===window.parent){document.getElementById('_wp_unfiltered_html_comment_disabled').name='_wp_unfiltered_html_comment';}})();</script>
    			</form>
    			</div><!-- #respond -->
    	
    </div>
                                    </div>
                                    <!--Comments End-->
    
    2) here's what shows up when I inspect it(after page loads)
    <!--Comments Area-->
    <div class="comments-area text-left">
                                         
    
    			<!-- If comments are open, but there are no comments. -->
    
    	 
    
    <div id="respond" class="respondbg"><div class="swpm-login-to-comment-msg">Please login to comment.</div></div>
                                    </div>
    <!--Comments End-->

    3) Finally, here’s what I found by searching throught the page for the keyword comments:

    <script type="text/javascript">
                jQuery(document).ready(function($) {
                    $('#respond').html('<div class="swpm-login-to-comment-msg">Please login to comment.</div>');
                });
            </script>
Viewing 2 replies - 1 through 2 (of 2 total)
  • Moderator t-p

    (@t-p)

    when the page is loading the Leave a Reply and comment box is there….but after it loads, it’s replaced by Please login to comment

    Neither I see the comment box or the message asking me to login to comment.

    I have allowed comments on all my blog posts and don’t require a user to login to comment.

    If that’s done, then where you create/edit posts or pages in admin, check if you have ticked comments for your posts/pages in the “discussion” box below the editor. If you don’t see the “discussion” box there, in the ‘screen option’ dropdown field (located near the top right), there are tick-boxes to show the ‘discussion’ box for the posts/pages. Tick mark it. In the ‘discussion’ box below the post/page editor, you can then allow/disallow comments for the page.

    If that’s also done, then to rule out any plugins/theme conflict, try:
    – deactivating ALL (yes all) plugins temporarily to see if this resolves the problem (plugin functions can interfere). If this works, re-activate them individually (one-by-one) to find the problematic plugin(s).
    – switching to the unedited default Theme (Twenty Seventeen.) for a moment using the WP dashboard to rule out any theme-specific issue (theme functions can interfere like plugins).

    Thread Starter sitinuriatistudio

    (@sitinuriatistudio)

    t-p:

    You have to scroll down quickly, but it does appear….if I could attach a screenshot I could show you.

    I don’t want to affect a live production site my deactivating all the plugins….

    Hopefully, someone else has some ideas.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Comment area replace with login to comment’ is closed to new replies.