Support » Fixing WordPress » Comment Area is NOT showing up on Posts

  • I have comments enabled in my Discussion Settings, AND in my individual post settings, the box that says “Allow Comments” is checkmarked.

    However, when I visit my post/pages. There is no comment box/area.
    Currently, I have installed the Disqus plugin for comments, and it is not working. However, before I had Disqus installed, the native WordPress comments were also not working.

    Here is my site url: http://www.lifeinkaizen.com
    Here’s a sample post page: http://lifeinkaizen.com/sample-post-page/

    As you can see, there is no comment box area showing up.

Viewing 14 replies - 1 through 14 (of 14 total)
  • In the WordPress admin go to
    1. Genesis > Theme Settings
    2. Scroll down to Comments and Trackbacks.

    Check the boxes for where you would like comments to appear – Posts, Pages or Both.

    Oh okay!
    Thank you so much 🙂
    I didn’t realize there was an additional set of comment settings in the Genesis tab.

    You’re welcome.

    That has tripped me up before – I tend to forget that setting is there. If that solves the problem, please mark this thread as resolved.

    403laura

    (@403laura)

    I am having this same issue with my buddyboss theme. I followed their instructions and went to “screen options” checked the discussion and comment boxes, then scrolled down and checked the “allow comments” box and then clicked “update.” Still after doing that there is no comment box showing up on my individual posts. I dont post comments on the pages as that is just the directory to get to the posts. Is there something I’m missing? Here is a link to one of the posts I am trying to put a comment box into http://getjobhelp.ca/tailor-resume-stay-track/

    Same problem here – anybody has any suggestion on how to trace (and solve) the problem of comment sections not appearing?

    I’ve noticed that if I add a comment myself via the backend, under a specific post, that that will appear, but this is too cumbersome a way of opening up comments on all posts.

    I wonder if anyone monitors this site? I am still waiting for some assistance with this issue.

    @403lauria – The comment box is showing up for me when I visit your site at the link you provided in the earlier post.

    @leopardct – What theme are you using? Can you provide a link to your site?

    Thank you @kwbridgey. Yes, now the comment box is showing up because I grew tired of waiting for a fix and installed the WP Advanced comment plugin today. @leopardct, you might want to try the same thing if you continue to experience the same issue. Here’s the link https://en-ca.wordpress.org/plugins/wp-advance-comment/

    @kwbridge, you have mentioned in one reply above, advise shown below, in order to get the comments appear under posts;

    “In the WordPress admin go to
    1. Genesis > Theme Settings
    2. Scroll down to Comments and Trackbacks.”

    Where to find this ‘Genesis’? Do you mean WordPress admin is the Dashboard area or somewhere else?

    I have the same problem of not appearing the comment box under the posts in my StrorFront themed site.

    My problem was resolved.

    Thanks.

    Hi there,

    I am using a standard WP theme, and comments box not showing up on the posts older than 1 month.

    My settings are:
    – comments enabled in my Discussion Settings
    – in my individual post settings, the box that says “Allow Comments” is checked.

    Any suggestions?

    Edit: My bad, there was another option like ” Automatically close comments on articles older than … days”. Unchecked it, and problem solved.

    • This reply was modified 1 year, 8 months ago by  Ozgur Nevres.
    • This reply was modified 1 year, 8 months ago by  Ozgur Nevres.
    • This reply was modified 1 year, 8 months ago by  Ozgur Nevres.
    • This reply was modified 1 year, 8 months ago by  Ozgur Nevres.

    Thanks Ozgurnevres,
    You tip worked for me. Now comment box is appearing on my blog.
    VowBlog

    Hi there,

    All of a sudden my comments are missing on my site. I can see them on the post editor page but on the public facing site, it just says “loading” where the comments should appear. I’ve tried deactivating the few plugins I’ve added recently, but it doesn’t seem to make a difference. I have bulk edited my posts and pages to ensure they allow for comments, as well as checked my screen options. Any ideas? My theme is Affinity and my site is http://www.wanderlustwayfarer.com

    Thanks!

    • This reply was modified 1 year, 8 months ago by  wander63.

    I’m using Elementor Free version and wanted to know how to add a comment box.
    If it’s possible with the free version.
    Any help is appreciated.
    Thank You
    Rodger

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Comment Area is NOT showing up on Posts’ is closed to new replies.