Support » Fixing WordPress » Comment Area is NOT showing up on Posts

Viewing 13 replies - 1 through 13 (of 13 total)
  • Comment could have been disabled in specific post also. To check, go to edit post screen in admin panel. In the top you can find Screen Options. Enable Discussion. Can you please check there once?

    Hi Nilambar, thanks for your comment!

    I have checked there as well: http://d.pr/i/Y4Xyr but the comments section is not appearing even though I have enabled both discussion and comments check box.

    Is there something else that I might be missing? Or is this a CSS issue (not that i have any clue on that…) Please let me know. Thank you!

    Did you check this metabox in the bottom? https://prnt.sc/fvidge

    Hi Nilambar, yes I have also checked the metabox at the bottom: http://d.pr/i/FkXPfy but the comments section is still not showing up 🙁

    Please check out this article:
    http://metinsaylan.com/4571/how-to-enable-comments-for-all-posts-in-wordpress/

    🙂

    By the way I just activated twenty fifteen theme on my local machine using WAMP server and I don’t see any problem with the theme.

    Thanks, Saurabhsaneja!

    I have read the article but am clueless to where would I put the code in? As I have no coding experience, and the article did not share what file & where is it located atto open and edit it, I can’t understand it.

    Are you able to share with me in more details?

    Thanks a lot for your help! 🙂

    Once I’ve added the code in the file, it is showing up ” Warning: Missing argument 2 for wpdb::prepare(), called in /home1/jcsm9554/public_html/wp-content/themes/blog-way/functions.php on line 11 and defined in /home1/jcsm9554/public_html/wp-includes/wp-db.php on line 1291

    Warning: Missing argument 2 for wpdb::prepare(), called in /home1/jcsm9554/public_html/wp-content/themes/blog-way/functions.php on line 12 and defined in /home1/jcsm9554/public_html/wp-includes/wp-db.php on line 1291 ” on my actuall http://www.lifeonleicester.com page.

    Am I missing anything?

    This is what I did within the code: http://d.pr/i/xFiM7M
    This is what it showed up on my blog: http://d.pr/i/NGndG2

    Hey,

    I am looking into it. By the way you should always create a child theme and add php code to child theme’s functions.php file

    Can you open your wp-config.php file and tell me whats in place of ‘wp_’; if it’s not ‘wp_’;

    `$table_prefix = ‘wp_’;’

    Thanks,

    Saurabh

    Hey,

    This would work if the table prefix is ‘wp_’ I just modified the code. If your table prefix is something else; I will use that prefix first on my WordPress install and then give you the new code

    function enable_comments_for_all(){
        global $wpdb;
        $wpdb->query( $wpdb->prepare("UPDATE $wpdb->posts SET comment_status = 'open' WHERE ID IS NOT NULL")); // Enable comments
        $wpdb->query( $wpdb->prepare("UPDATE $wpdb->posts SET ping_status = 'open WHERE ID IS NOT NULL'")); // Enable trackbacks
    } enable_comments_for_all();

    Remove the code once you see that “leave a comment option is enabled” below the post.

    lifeonleicester

    (@lifeonleicester)

    Hi Saurabhsaneja, thanks for following up with my questions!

    I am so sorry but I do not have a coding background, and I have no idea what you mean by your previous comments 🙁

    I’ve tried searching for wp-config.php but I can’t find it and I am very lost… would it be alright if we can jump on skype and I can share my screen with you live?

    Let me know what you think. Thank you so much for your help!

    Cheers,
    Jasmine

    Saurabh Saneja

    (@saurabhsaneja)

    Sure; But first you should have access to the database because direct modifications can be made from the database if database’s wp_posts table has comments closed selected

    lifeonleicester

    (@lifeonleicester)

    Thanks, Saurabh!

    Sorry, I really do not quite understand by having access to the database? Which database are you referring to? I am unsure where I could get access to that and am not familiar with any at the moment.

    If you could reach out to me personally via lifeonleicester@gmail.com, that will be great! 🙂

    Saurabh Saneja

    (@saurabhsaneja)

    My email address is saurabh250183@gmail.com I am sending you an email with the details I need from you right away!!

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Comment Area is NOT showing up on Posts’ is closed to new replies.