WordPress.org

Forums

[resolved] [Command Line Interface: WP-CLI] Problem installing WP-CLI: cannot locate php.in (3 posts)

  1. jplew
    Member
    Posted 2 years ago #

    Hi: when I try to install WP-CLI on my Mac using the curl http://wp-cli.org/installer.sh | bash command, I get the following error message:

    The detect_unicode setting must be disabled.
    Add the following to the end of your php.ini:
    detect_unicode = Off

    A php.ini file does not exist. You will have to create one.
    If you can not modify the ini file, you can also run php -d option=value to modify ini values on the fly. You can use -d multiple times.

    PHP is not installed using the OS X bundle or any kind of package, but it is working using MAMP. Therefore my php.ini file is located here: /Applications/MAMP/conf/php5.4.4/php.ini

    Is there any way to tell the installer to use that ini file by using symlinks or changing PATH variables, or do I need to install PHP using one of the former methods? Thanks.

  2. Jaime Martinez
    Member
    Posted 1 year ago #

    Looks like you got it fixed on GitHub, could you close this ticket? Thnx!

  3. jplew
    Member
    Posted 1 year ago #

    sure thing! it's closed.
    Here's the solution for any of you fine folk from the future: https://github.com/wp-cli/wp-cli/issues/466

Topic Closed

This topic has been closed to new replies.

About this Topic