Support » Plugin: Advanced Custom Fields: Extended » Columns stopped working

  • Resolved regisit

    (@regisit)


    I was using columns for admin layout of fields. They’ve now stopped working with all fields in a single column. Looking at the plugin site now, it says Columns are Pro only.

    Have you made a selection of field types that we were able to use now only available to Pro users?

    In your blog post of 27th Oct you say “I want to reassure everyone right away, the support for the free version will be maintained, and the features currently available will remain so.

    Is this not the case?

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Konrad Chmielewski

    (@hwk-fr)

    Hello,

    Thanks for the feedback! Don’t worry, the Columns Field is still absolutely included in the free version of ACF Extended. There is a new “Border” setting and a “Column Auto” size that have been added to the Pro version, as explained in the Columns Field documentation and in the 0.8.8.3 Changelog.

    As you can see on the website, the Columns field now has both Free & Pro tags, and the original field is still free.

    I just tested The Columns Field with ACF Extended Free 0.8.8.2 and updated to the new 0.8.8.3 version from the WordPress admin, and it works correctly. See video of the test: https://i.imgur.com/f78hegC.mp4

    The new version made some changes to the CSS style tho, so maybe you got some cache in your browser. Can you please try to clear your browser cache in order to correctly apply the new update? The problem most likely come from there. Here is a guide on how to clear cache on Chrome.

    Hope it helps!

    Have a nice day.

    Regards.

    Thread Starter regisit

    (@regisit)

    Ok, thanks for confirming. Perhaps a little key as to what the Pro icons mean would help avoid confusion.

    However, cleared cache (browser, Rocket and Opcache) and still no columns. Also tried resaving field group, using another browser and incognito.

    Any other ideas?

    Thread Starter regisit

    (@regisit)

    Seems to be an issue with CSS:

    .acf-fields.acfe-column-wrapper>.acf-field.acf-field-acfe-column[data-columns=”2/12″] {
    width: 16.66666%;
    float: left; – missing
    }

    Plus acf-input.css line includes:
    .acf-field {
    margin: 15px 0;
    clear: both; – destroys floats on each field!
    }

    Add float:left and remove clear:both and then it display in columns.

    Plugin Author Konrad Chmielewski

    (@hwk-fr)

    Hello,

    I just ran some additional tests, and found a bug that is preventing columns to work when using the Field Group “Seamless Style” setting (both for Free & Pro version). Is that your case?

    If so, you can add the following code in your functions.php file in order to fix the issue:

    add_action('admin_head', 'acfe_fix_seamless_style_columns');
    function acfe_fix_seamless_style_columns(){
        ?>
        <style>
            .acf-postbox.seamless > .inside.acfe-column-wrapper{
                display: -webkit-box !important;
                display: -ms-flexbox !important;
                display: flex !important;
                -ms-flex-wrap: wrap !important;
                flex-wrap: wrap !important;
            }
        </style>
        <?php
    }
    

    Screenshot of the fix applied: https://i.imgur.com/zd2MVKi.png

    I’m adding the fix to the to-do list for the next patch. I’ll let you know as soon as it’s up, so you can remove that code.

    Sorry for the inconvenience.

    EDIT: I just saw your answer. The Columns field has been enhanced and now use CSS Flexbox instead of float. Please use the code I provided above it should fix your problem.

    Regards.

    Thread Starter regisit

    (@regisit)

    Thanks Konrad. Can confirm the patch fixes it.

    Great support! 🙂

    Just one comment if I may. Looks a tiny bit untidy as all fields briefly appear stacked and full width before realigning into columns. If it were possible to fix that it would be good.

    Plugin Author Konrad Chmielewski

    (@hwk-fr)

    Hello,

    I’m glad to hear it now works as expected 🙂

    Unfortunately I can’t make the column fully “natural”, as ACF itself needs to some time to correctly initialize its Javascript, and ACF Extended depends on that to generate the columns.

    I will try to mitigate it a bit more in the next patch, but it will never be as natural as hard-coded columns. Note that this behavior is also visible in the previous versions, as this is just how the system works.

    BTW, the “initialization blink” you see should be only visible when you clear your browser cache or force the page refresh, as the browser will completely reload the JS. If you navigate normally from one page to an another, you should not see it, since your brower will load the javascript more quickly. A similar behavior can be seen with the native ACF Tabs field when used on a page which have many fields. ACF also takes some time to move the fields to the correct tab.

    Have nice day!

    Regards.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.