WordPress.org

Ready to get started?Download WordPress

Forums

Custom Content Type Manager
[resolved] Columns for Tags and Taxonomy (missing) (7 posts)

  1. Yawarakaimono
    Member
    Posted 2 years ago #

    I checked 'Customize Columns' and the fields for a custom type in the 'Columns' tab;

    why are the lines in the plugin panel for Tags and Category light blue? Is it to indicate that these are WordPress Taxonomies?

    But why do these fields not show up in screensettings, column-heading or data-columns for the edit page of the custompost?

    why is the value for a tag displayed in blue, under heading 'Date', immediately after completing a quick edit?

    http://wordpress.org/extend/plugins/custom-content-type-manager/

  2. fireproofsocks
    Member
    Plugin Author

    Posted 2 years ago #

    Yes: blue means they are taxonomies, so their values come from entirely different places in the database. I think this is a bug... can you please fill out a bug report in the bug-tracker? I should warn that this particular part of the WP manager has been very difficult to customize, so I've had a lot of trouble making WP support this particular feature.

  3. fireproofsocks
    Member
    Plugin Author

    Posted 2 years ago #

    Ah, WP changed its functions: http://codex.wordpress.org/Plugin_API/Filter_Reference/manage_edit-post_type_columns

    In WP 3.1, manage_edit-${post_type}_columns has been supplanted by manage_${post_type}_posts_columns.

    So yeah, I need to rewrite this so it works with WP 3.5.

  4. fireproofsocks
    Member
    Plugin Author

    Posted 2 years ago #

    Ok, this is fixed in the latest version: http://downloads.wordpress.org/plugin/custom-content-type-manager.zip

    The fix will be in 0.9.7.

  5. Yawarakaimono
    Member
    Posted 2 years ago #

    0.9.7 is the version that I am using.

  6. fireproofsocks
    Member
    Plugin Author

    Posted 2 years ago #

    Did you manually install the dev version (0.9.7-dev)? I have not yet released 0.9.7.0-pl. The current public release is 0.9.6.7-pl. This issue is fixed on the dev branch.

  7. Yawarakaimono
    Member
    Posted 2 years ago #

    OK, a manual install solved the problem -
    Thanx for the quick fix!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic