Support » Plugin: Genesis Columns Advanced » column shortcodes prevents excerpt from showing

  • Resolved GratefulDeb

    (@eventermom)


    Consistently, when a post or page has the column shortcodes it seems to “block” the post excerpt from showing on the archive page. How can I prevent this?

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Nick Diego

    (@ndiego)

    Hi GratefulDeb,

    Are you able to point me to a page/archive that displays this behavior. That would help a lot in diagnosing.

    Thanks,
    Nick

    https://goldivagoldens.com/testimonials/
    I’m still formatting it – but “Jill Simmons” testimonial uses the column shortcodes and only the featured image appears.

    Plugin Author Nick Diego

    (@ndiego)

    Ah yes, I see. WordPress does not generate automatic excerpts from content inside of shortcodes. Since the first content on this page is wrapped in shortcodes, nothing is displaying.

    A convenient way around this it to use manual excerpts. This functionality is available for posts. I see that the testimonials on your site appear to be a custom post type? Is this correct, or are they just categorized standard posts? If just posts, then you should have the ability to add manual excerpts to all testimonials. If a custom post type, hopefully the developer enabled this functionality. If not, I can show you how to do it. It’s just a simple edit to your functions.php file.

    Best,
    Nick

    I was trying to avoid that for client ease, but I guess I’ll have to do it. I have run into this on multiple sites, so it would be nice if there was a permanent work around to automatically generate the excerpt even with the shortcodes.

    Plugin Author Nick Diego

    (@ndiego)

    Yeah so do I! You can try adding something like the following to your functions.php file, but I have had mixed success depending on what content is actually inside of the shortcodes.

    add_filter( 'the_excerpt', 'shortcode_unautop');
    add_filter( 'the_excerpt', 'do_shortcode');

    Thanks. that didn’t work. I’ll use the other method – but would be a nice fix on many levels.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘column shortcodes prevents excerpt from showing’ is closed to new replies.