Support » Theme: Hueman » Column shortcode stopped working after update

  • Resolved JackGraal

    (@jackgraal)



    I’ve recently updated my customized Hueman theme to the newest version and started to use child theme for all changes. Everything seems to be done, but I’ve noticed that columns shortcode doesn’t work anymore.

    I’m using the Hueman Addons plugin and Shortcode Ultimate plugin.

    This Image shows what’s wrong: http://imgur.com/a/N8YD9

    The ‘1’ and ‘2’ should be in the same row.
    The ‘3’ should be below as it is not included in any rows or columns.

    You can see the live version here: blog post

    The problem occurs anytime [column] shortcode is used.

Viewing 15 replies - 1 through 15 (of 17 total)
  • Hi Jack. Wondering if you’re using the current version of the Hueman Add-ons plugin because the class names on your columns don’t match what the current Add-ons plugin generates. It also appears that the ‘ last=”true” ‘ parameter is missing from the second column. Since the columns don’t contain the class needed to set the width the content is being displayed at its native width. This causes the following paragraph to be displayed in the normal HTML flow regardless of the su-row.

    Yes, I’m using the newest version of the theme 3.17 and Hueman Addons 1.0.4.

    What is the column shortcode syntax you’re using?

    Something like this:

    [row]
    [column size=”1/3″]XXX[/column]
    [column size=”2/3″]YYY[/column]
    [row]

    I didn’t change anything regarding shortcodes when upgrading the theme from the old version.

    Check the Responsive Columns section in this document:
    http://docs.presscustomizr.com/article/246-hueman-addons-how-to-use-the-shortcodes

    I changed it the way it is written there and it worked – that’s the good part.

    So the bad part is that I have to manually edit all my posts, change ‘1/3’ into ‘one-third’ (or any other thing like that in the same way) and add ‘last=”true’ to all columns?

    And the [row] shortcode can be removed, right?

    I have to manually edit all my posts

    I think “yes” unless you can write a SQL query to do through the database and update the posts programmatically.

    and add ‘last=”true’ to all columns?

    Not all columns; only the last column in the sequence.

    the [row] shortcode can be removed

    I don’t believe a row shortcut is included in the Add-ons plugin. I thought you were using the [su_row] shortcut. In any case you shouldn’t need it but you should probably do a test on one post to verify that.

    Ok, so I have a few thing to do.

    Thanks for your help 🙂

    You’re welcome; glad to help.

    There still is one problem left – when I create new columns, they use numbers instead of words (“1/2” instead of “one-half”). What can I do about that?

    Something must be wrong between Hueman shortcodes and Shortcodes ultimate.

    How can I deactivate Hueman shortcodes without deinstalling it (so I can use the sharebar)?

    when I create new columns, they use numbers instead of words (“1/2” instead of “one-half”).

    How are you creating them in the posts? There shouldn’t be any conflict between the Add-ons and SU; they use different codes.

    I’m using “Add shortcode” button in the post editor. It opens a list of SU shortcodes.

    I don’t really need the shortcodes from Hueman Addons plugin so is there a way to deactivate them? Maybe via a function or something like that?

    I think I went off-track here by assuming you were using the Add-ons shortcodes for the columns. If you’re not using those, but using SU shortcodes instead, then you need the row. So your shortcodes should look like this:

    [su_row]
    [su_column size=”1/3″]
    content
    [/su_column]
    [su_column size=”1/3″]
    content
    [/su_column]
    [/su_row]
    content

    The above should result in:

    content………..spaces………….content………..

    content…………………………………………

    You don’t need to do anything to disable the Add-ons shortcodes. As I mentioned earlier the Add-ons and SU use different codes so there is no conflict there. If you use the SU codes like the above, and assuming there aren’t any other plugin conflicts, it should work.

    Nope, when I make it like that shortcodes are not working at all (visible in the frontend as [su_xxx]).

    There’s an option in SU to set a prefix. When i set it to ‘su_’ the conflict is no more, but I’d need to change ALL shortcodes (not only columns) to have a ‘su_’ prefix.

    I don’t want it like it. I’ve been using SU for years and it worked fine with just normal “prefix free” shortcodes.

    It worked fine with the shortcodes build inside Hueman theme, but the updated Hueman Addons plugin changed how columns work and, for example, how a highlight shortcode works.

    All in all – I’d like to deactivate the “shortcode” part of the plugin 🙂

    The SU prefix is there so that you can ensure that the shortcodes will be unique. The same goes for any custom functions you write; they should be prefixed with something that ensures they will be unique. Then you are much less likely to encounter the current issue.

    You have a couple of options:
    1. You can change the Hueman Add-ons plugin file directly but your changes will be lost when you update the plugin.

    2. You could copy the Hueman plugin and give it another name, modify that plugin and activate it, then deactivate the Hueman Add-ons plugin. You would still need to check the Hueman plugin whenever it’s updated to see if there have been any changes, and copy those changes to your custom plugin.

    3. Modify your existing SU shortcodes to add a prefix now so you don’t have to worry about it in the future.

    The Hueman shortcodes are loaded in the following file:

    /wp-content/plugins/hueman-addons/hueman-addons.php

    To disable the shortcodes, comment out (using //) or remove the line that loads the shortcodes template file:

    /**************************************************************
    ** SHORTCODES
    **************************************************************/
    function hu_shortcodes_actions() {
        //  load_template( dirname( __FILE__ ) . '/inc/shortcodes.php' );
    }
Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘Column shortcode stopped working after update’ is closed to new replies.