Support » Plugin: WordPress Backup to Dropbox » "Column 'offset' cannot be null"?

  • Resolved iltrev

    (@iltrev)


    I think this happened after the last update, but I’m not completely sure about it.
    Anyway, I was warned by my maintainer that my error_log_php file was getting very big (it reached over 270 MB in size), so I took a look at it and found out tons of lines like this one:

    [22-Dec-2015 08:47:42 UTC] WordPress errore sul database Column ‘offset’ cannot be null per la query INSERT INTO’wp_wpb2d_processed_files'(‘file’,’uploadid’,’offset’) VALUES ([$PATH_TO_FILE], NULL, NULL) fatta da do_action_ref_array, call_user_func_array, run_dropbox_backup, WPB2D_BackupController->execute, WPB2D_BackupController->backup_path, WPB2D_Processed_Files->add_files, WPB2D_Processed_Base->upsert

    The error is the same for all the files being sent to dropbox, the only change is in $PATH_TO_FILE.
    I had to stop wpb2db to avoid this issue, so any help would be *VERY* appreciated…

    Thanks in advance

    https://wordpress.org/plugins/wordpress-backup-to-dropbox/

Viewing 15 replies - 1 through 15 (of 34 total)
  • +1 for the report

    3 of my sites are down due to huge server storage (mostly form error_log) within 3 or more days after the last update

    Same with me

    +1….

    Happy I’m not the only one seeing this, but would love to see it fixed soon.

    Files still seem to copy, but the backup eventually fails and then starts again in a few minutes

    me too.
    [Tue Jan 05 14:24:09 2016] [warn] mod_fcgid: stderr: WordPress database error Column ‘offset’ cannot be null for query INSERT INTO wp_wpb2d_processed_files (file, uploadid, offset) VALUES (‘/home/hairybarsnacks.com/public_html/blog/wp-content/uploads/2014/04/20140409_125304-e1397044830284-150×150.jpg’, NULL, NULL) made by do_action_ref_array, call_user_func_array, run_dropbox_backup, WPB2D_BackupController->execute, WPB2D_BackupController->backup_path, WPB2D_Processed_Files->add_files, WPB2D_Processed_Base->upsert

    Same issue on a second site. This is becoming alarming.

    I came across this problem as well. Looking at the code I think the issue is that the offset column on the wp_wpb2d_processed_files table should be auto-increment.

    I was able to resolve the issue by making this change to that table:

    ALTER TABLE wp_wpb2d_processed_files
     ADD INDEX 'offset' ('offset'),
     CHANGE 'offset' 'offset' INT(11) NOT NULL AUTO_INCREMENT;

    I don’t think that this change will be preserved when the plugin is updated, so if there is a future update that doesn’t fix this bug, you’ll need to re-run this statement after the update.

    Same thing happened here. Hope the next update will include @gavinbrown‘s fix.

    Hi everyone,

    same issue here – caused my server to crash.

    Could you please suggest what I should do to restore my website so I can delete the plugin in the meantime ?

    Thanks for your help,

    Regards.

    @robert

    As per https://codex.wordpress.org/Managing_Plugins#Uninstalling_Plugins

    – log onto your server via ftp or cpanel
    – navigate to the plugins folder (should be /wp-content/plugins)
    – delete the wpb2db folder, or move it away from the containing folder if you want to put it back in the future

    (still waiting for a feedback by the author, btw)

    Thanks for your help !

    My site is back online.

    Regards.

    Plugin Author Michael De Wildt

    (@michaeldewildt)

    This has been fixed in version 4.4.1. Sorry for the delay.

    RichHelms

    (@richhelms)

    Sorry but I have 4.4.1 installed and it is still happening

    RichHelms

    (@richhelms)

    If I execute in PHPMyAdmin

    INSERT INTO bt101_wpb2d_processed_files (file, uploadid, offset) VALUES (‘/home/richhelm/public_html/course/wp-content/themes/uber/single-project.php’, NULL, NULL)

    I get the error #1048 – Column ‘offset’ cannot be null

    If I try
    INSERT INTO bt101_wpb2d_processed_files (file, uploadid, offset) VALUES (‘/home/richhelm/public_html/course/wp-content/themes/uber/single-project.php’, NULL, 0)

    it works

    The table is defined as
    CREATE TABLE IF NOT EXISTS bt101_wpb2d_processed_files (
    file varchar(255) NOT NULL,
    offset int(11) NOT NULL DEFAULT ‘0’,
    uploadid varchar(50) DEFAULT NULL,
    UNIQUE KEY file (file)
    ) ENGINE=InnoDB DEFAULT CHARSET=latin1;

    so it should default to 0 but why not just put in 0

    This appears to be a MySQL issue with some version or interface. Problem is I can not change the version of MySQL and it looks like I am not alone.

    stevejharris

    (@stevejharris)

    i have upgraded to 4.4.1 and i am still having the same problems. time to disable until a fix is sorted.

    dvsmith

    (@dvsmith)

    Also having this issue under 4.4.1.

Viewing 15 replies - 1 through 15 (of 34 total)
  • You must be logged in to reply to this topic.