WordPress.org

Forums

TablePress
[resolved] Column hidden but active (9 posts)

  1. zarc
    Member
    Posted 1 year ago #

    Découvrez le navigateur Google Chrome doté d'une fonction de traduction automatique.Télécharger Google ChromeIgnorer
    Traduction
    Hello

    Tablepress is very usefull .
    However I have a question:

    Imagine four columns (for example : " name", " firstname ", " phone ", " specialty " =>
    "House ," " Gregory ", " 011002003004 ", " internist " )

    We seek specialty " internist ." The search engine finds the word. OK
    It seeks " nephrologist " specialty. Tss , tts not OK, because the word does not exist. Normal.
    You tell me add the word " nephrologist " in the specialty column. OK.

    But it turns out that Dr. House is nephrologist , but infectious disease and I would like Dr. House is also entering a whole series of keyword. I want that these keywords are hidden.

    In fact I have about 100 keywords to find Dr. House and I do not want to clutter the display with the keyword column .

    = > My question
    OK , hide from tablepress function to hide a column.
    I would like to hide a column allowing possible access to the words contained in the column. This would look without displaying a list of keywords relevant to the public.
    Is there a solution ?

    sincerely
    Google Traduction pour les entreprises :Google Kit du traducteurGadget TraductionOutil d'aide à l'export
    Désactiver la traduction instantanéeÀ propos de Google TraductionMobileConfidentialitéAideEnvoyer des commentaires

    http://wordpress.org/plugins/tablepress/

  2. TobiasBg
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    thanks for your question, and sorry for the trouble.

    I think I understood what you mean, and the solution is to hide the column in a different way: Instead of hiding it on the "Edit" screen, you should hide it with CSS.
    So, add a fifth column with all the other search words relevant for the entry.
    Then, add this to the "Custom CSS" on the "Plugin Options" screen of TablePress:

    .tablepress-id-123 .column-5 {
      display: none;
    }

    (Adjust the table ID and column number as necessary.)

    Regards,
    Tobias

  3. zarc
    Member
    Posted 1 year ago #

    I just tested, it's perfect
    When I finish my new website .. for a hospital in France, rest assured that I will make a "donation" ..
    sincerely thank you
    House thank you: now you can find it with the word "TobiasBg"!

  4. zarc
    Member
    Posted 1 year ago #

    Resolved

  5. TobiasBg
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    no problem, you are very welcome! :-) Good to hear that this helped!
    And thanks for wanting to donate, I really appreciate it!

    Best wishes,
    Tobias

    P.S.: In case you haven't, please rate TablePress here in the plugin directory. Thanks!

  6. zarc
    Member
    Posted 1 year ago #

    It's done!

  7. TobiasBg
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    thanks, that's very nice of you!

    Regards,
    Tobias

  8. frogstar42
    Member
    Posted 11 months ago #

    I am not certain this is the same as my final problem with the amazing Tablepress. I'm almost done my project. The last one is vital. I have a database with two hidden columns. One is "Availability: YES or NO. I want to NEVER EVER show the NO entries, but currently all searches still display the NO matches, even if the column itself is hidden.

  9. TobiasBg
    Member
    Plugin Author

    Posted 11 months ago #

    Hi,

    as you have opened a separate threa at http://wordpress.org/support/topic/tablepress-search-displays-matches-to-hidden-columns , I'll reply there shortly.

    Regards,
    Tobias

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • TablePress
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic