WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Colours not loading correctly

[Resolved] Colours not loading correctly

  • Hi,

    I’d set up the Events Category Colors plugin which was working exactly as expected; different categories had different colours set etc.

    I’ve updated to The Events Calendar and The Events Calendar Pro and now all the different events (in different categories) are using the same colour (blue).

    Additionally, the previous / next (week) links don’t load any colour, but if you refresh the page the same blue colour loads for all posts.

    Am I missing a setting somewhere or could this be a bug?

    You can see an example of this here: http://squeakygatestg.wpengine.com/calendar/

    Thanks in advance for any help!

    James

    https://wordpress.org/plugins/the-events-calendar-category-colors/

Viewing 15 replies - 1 through 15 (of 52 total)
  • Plugin Author Andy Fragen

    @afragen

    This is a bug in the week view of ECP. When it gets fixed there will be colors. We have to wait for Modern Tribe for this one. I’ll see if I can’t figure out a template override to fix it.

    Thanks! I’m having the exact same problem.

    leahkoerper

    @leahkoerper

    Modern Tribe Support Rep

    Andy, to confirm- is this a part of the issues we’ve been discussing with you and have ticketed? I just want to make sure this is on the radar 🙂

    Best,
    Leah

    Plugin Author Andy Fragen

    @afragen

    Hey Leah, thanks for chiming in. Yes, this is one of the issues where the week view doesn’t correctly include the category class tag.

    Thanks for keeping tabs on us. 🙂

    leahkoerper

    @leahkoerper

    Modern Tribe Support Rep

    Great, thank you Andy!

    mending, we are actively working on getting this fixed 🙂 Thanks for your patience!

    Plugin Author Andy Fragen

    @afragen

    Leah, let me know if there’s anything I can do to help.

    Thanks 🙂 Looking forward to it.

    Hi Andy, Leah,

    Thanks for the update on this, and confirmation that I’m not going mad trying to work out what’s gone wrong.

    Is there anything short-term I can do to get this working whilst an update is being worked on?

    Thanks,

    James

    Plugin Author Andy Fragen

    @afragen

    James,

    I’ll see about pushing out an update that reverts to the default behavior for ECP. Be aware the default behavior is that blue background and white text.

    If I have time I’ll see if I can create a template override for it but that will take more effort on your part to implement.

    Andy

    Hi Andy,

    Thanks for getting back to me; whilst I really appreciate what you’re proposing, it seems a lot of work for little gain.

    The entries are already showing up as the default colours; I can change the CSS to force the background / text colour for the next / previous links where the colours break at the moment.

    Thanks,

    James

    ** Duplicate, please ignore **

    Plugin Author Andy Fragen

    @afragen

    James,

    v3.4.4 should make no changes to the week view.

    As for the Previous and Next Week links, nothing in this plugin should effect them.

    Colors are no working on the “Orgaziner” nor the “Venue” page either. They are not showing at all as they are on the List view.

    Plugin Author Andy Fragen

    @afragen

    The plugin isn’t designed to show on Organizer and Venue pages. I’ll take that as a feature request.

    Plugin Author Andy Fragen

    @afragen

    mending, can you provide a URL?

Viewing 15 replies - 1 through 15 (of 52 total)
  • The topic ‘[Resolved] Colours not loading correctly’ is closed to new replies.