Support » Plugin: The Events Calendar: Category Colors » Colors not showing after 7.0.0 update

  • Resolved boro666

    (@boro666)


    After the last 7.0.0 update with code rewrite colors suddenly stopped showing in all views. Also styles are not applying correctly, because font colors go back to the Events Calendar settings. Rolling back plugin to 6.7.1 solves the problem.

    I’m using PHP 7.4 and WordPress 5.9.3, so it’s not minimal requirements problem. Events Calendar ver. is 5.14.2.1.

Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Author Andy Fragen

    (@afragen)

    You might need to re-save your Category Colors settings or add ?refresh_css to the calendar URL.

    Thread Starter boro666

    (@boro666)

    Thank you for the quick response. I’ve tried that refresh_css command, but no luck. Also tried reapplying and saving again new colors. I’ve noticed that when I use “Restore defaults upon plugin deactivation/reactivation” the plugin settings are not resetting. All my colors and other settings stay the same.

    • This reply was modified 1 year, 10 months ago by boro666.
    Plugin Author Andy Fragen

    (@afragen)

    Can you share the calendar URL?

    Thread Starter boro666

    (@boro666)

    It’s my plugin testing site, so not much there: https://connect.firmyrodzinne.pl/kalendarz/

    Plugin Author Andy Fragen

    (@afragen)

    I’m looking but I’m not understanding why the selector in the CSS isn’t picking up.

    Still looking.

    Thread Starter boro666

    (@boro666)

    Thanks again for your support.

    Plugin Author Andy Fragen

    (@afragen)

    Strange as the CSS generated between the versions isn’t different.

    Do you have any caches browser, object, or page cache you can clear?

    Thread Starter boro666

    (@boro666)

    Purged CloudFlare cache but seems there’s no effect. In the older plugin version new settings and styles apply with no problems

    Plugin Author Andy Fragen

    (@afragen)

    Difference between the 2 versions is writing the CSS to a file and enqueuing versus adding the CSS inline.

    I can see that the CSS is added inline. I just don’t know why it doesn’t seem to be working on your site.

    Take a look at my test site, https://tribe.thefragens.net
    Very similar CSS as v6.7.1 and it’s working.

    Plugin Author Andy Fragen

    (@afragen)

    I think I found the problem. Stay tuned.

    Thread Starter boro666

    (@boro666)

    Sure, waiting for your response. I hope you’ll be able to find the problem with new code, because I really love your plugin. It’s one of those must haves for the Events Calendar 🙂

    Plugin Author Andy Fragen

    (@afragen)

    Just pushed hotfix in v7.0.1. Please let me know if it fixes for you. You will need to re-save settings or add the refresh_css query arg to the URL to re-write and re-save the CSS.

    • This reply was modified 1 year, 10 months ago by Andy Fragen.
    Plugin Author Andy Fragen

    (@afragen)

    I was copying code and forgot to remove the check for Events Calendar PRO where it shouldn’t have been. There was also a errant comma.

    Thread Starter boro666

    (@boro666)

    Hotfix 7.0.1 solved the problem, after using refresh_css. I have to say I’m really amazed by your support. Thanks again Andy! 😀

    Plugin Author Andy Fragen

    (@afragen)

    Be sure to rate the plugin. 😉

    Glad I was able to figure it out.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Colors not showing after 7.0.0 update’ is closed to new replies.