WordPress.org

Support

Support » Plugins and Hacks » The Events Calendar Category Colors » [Resolved] Colors not appearing

[Resolved] Colors not appearing

Viewing 15 replies - 1 through 15 (of 21 total)
  • Plugin Author Andy Fragen

    @afragen

    rockytt, very interesting. The plugin seems to be generating the proper css. Did you happen to add the gist code I mentioned in the FAQ to you functions.php? I ask because it looks like your event is being stripped of its category class tag. And that seems to be the problem.

    Hi Andy-
    I had not, but adding it in doesn’t seem to make any difference (that I can see-browser cache has been cleared)

    (remove_tribe_cat_once.php)

    Plugin Author Andy Fragen

    @afragen

    I don’t want you to add remove_tribe_cat_once. It looks like it’s there. I’ll try to get back to this thread throughout the day but my day job interferes. 😉

    BTW, just for fun, update to current version. You’re only one behind. 😉

    That was fun 🙂

    Was there a different function I was supposed to add?
    Totally understand about day job – I’ll be patient 🙂

    Hi rockytt, interesting. As Andy said it seems the category class is missing which means this plugin can’t work its magic.

    • Just to be clear, you do not have the remove_tribe_cat_once() function in place any more (hopefully you do not)?
    • Do you happen to be using a caching plugin such as W3 Total Cache or WP Super Cache, or a cache that operates above WordPress’s level?
    • Have you customized your event templates at all?

    Hi Barry,

    Well, in Andy’s first post he said to add the gist code, and when I followed the link at the FAQs it gave me the remove_tribe_cat_once() function. Was there something else I should have done instead?
    Didn’t work whether it was in place or not, but I’ll go ahead and remove it.

    No caching
    Have customized the small calendar on the home page a tiny bit, but not the main one.

    Yeah I think there was a slight misunderstanding there. Please do remove that function, for the time being at least – then let’s see how it all looks at that point.

    Yup – same as before my first post (and Andy’s response) – I’m sure I just missed something obvious, but for the life of me can’t figure out what it is-
    (Need to have more than one category/event setup?)

    I do also note the tooltip for that event in February isn’t displaying when you hover over it (in month view) … if that isn’t something you’ve customized could it be there is a conflict somewhere along the line?

    Are you in a position to run through the usual troubleshooting steps (deactivate other plugins and switch back to Twenty Eleven or Twenty Twelve, check if that solves the problem and reactivate one-at-a-time until the problem returns)?

    Deactivated everything except the 3 Events Calendar plugins, switched to Twenty Twelve, and still no color for the Feb event-

    Ok. Is it possible for you to do that again, leave it in that state and let me know (I’m around for the next 30mins if you are) so I can see how the markup looks?

    Sure – here’s a link to the calendar page –
    http://tech4realtor.com/glaaacc/events/2013-02/

    Thanks – while you’re still on, can you now deactivate The Events Calendar Category Colors then post back again?

    done

Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘[Resolved] Colors not appearing’ is closed to new replies.
Skip to toolbar